0

I cannot find the web sharing option in the system preferences under "Sharing"(where the web sharing is supposed to be). I am using Mac Os x 10.9.4

2

Warning: The normal user will be happy with Server.app

Apache is still available, but the user interface is gone. If you are comfortable configuring Apache the traditional way via config files, you can activate it by running sudo apachectl start from the shell. You find the config files in /etc/apache2. Be prepared to restore your configuration on OS updates.

1

Just run sudo apachectl start.

apachectl is a shell script and sudo apachectl start runs launchctl load -w /System/Library/LaunchDaemons/org.apache.httpd.plist as root, which modifies /var/db/launchd.db/com.apple.launchd/overrides.plist to enable apache permanently.

To make localhost/~yourusername point to ~/Sites/, run

echo '<Directory "/Users/'$USER'/Sites/">
  Options Indexes Multiviews
  AllowOverride AuthConfig Limit
  Order allow,deny
  Allow from all
</Directory>'|sudo tee -a /etc/apache2/users/$USER.conf

and run sudo apachectl restart.

To enable PHP, uncomment

#LoadModule php5_module libexec/apache2/libphp5.so

in /etc/apache2/httpd.conf and run sudo apachectl restart.

1

If you're not comfortable with the command line methods, you might consider installing MAMP, which offers a convenient GUI for starting, stopping and basic configuration: http://www.mamp.info/en/

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .