1

This may turn out to be two different questions/answers, but I suspect they're somewhat related. Let's see...

Among other things on my home network, I have a MacBook Pro (mid-2010) and a Macbook (late 2009), both running 10.9.5, and a 2nd gen AppleTV and a 3rd gen AppleTV, both fully updated.

When the Macbook is asleep, provided iTunes was running when it went to sleep, all my other devices can see its iTunes library, and wake up the Macbook to access it if they want to. But when the MacbookPro is asleep, nothing can see its iTunes library until I open the lid again.

When the AppleTV 2 is asleep, all my other devices can see it and select it as an AirPlay target. But when the AppleTV 3 is asleep, nothing can see it until I wake it up.

Obviously, I'd prefer it if all my devices could see the services on all my other devices, all the time—I understand this is what the Bonjour Sleep Proxy service is supposed to do. But I can't figure out why it's working for some devices, but not others.

Any clues?

EDIT: To answer the most common question I'd anticipate, yes, "Wake for network access" is checked in the Energy Saving prefs on both the laptops in question.

0

I eventually tracked this down to the behaviour of one of my Powerline adapters, specifically a TP-Link TL-WPA4220. For whatever reason, multicast traffic does not appear to correctly pass through the WiFi on this device, even with the latest firmware.

TP-Link have a related technical note on this, but it doesn't seem to apply to my particular device. In the meantime, I've just left the WiFi turned off on this adapter (still using it for two wired devices, including the 3rd gen Apple TV), and things seem to be working better again.

0

I had the same problem with TL-WPA4220 - the powerline wifi didn't seem to be passing multicast traffic to and from my Macbook Air (including Sonos, AirPlay to Apple TV, Dropbox LAN sync, and plain ping 192.168.1.255).

I tried reducing the TL-WPA4220 from 40MHz to 20MHz, and I don't know why, but everything seems to be working now:

As part of basic RF hygiene make sure that the 'WPA4220 has not defaulted to 300Mbps (40MHz) operation. This will rather monopolise the available 2.4GHz spectrum. The HH3 sensibly doesn't default to 40MHz width.

(from http://forums.sonos.com/showthread.php?t=38300#post215615)

  • Thanks for the tip... unfortunately, in my case at least, I had already set it to 20MHz. In other news, what does seem to have helped is turning off IGMP Snooping on my router, but haven't tested enough yet to definitively say whether that (or that alone) has fixed my issues. – calum_b Apr 7 '15 at 19:44
0

I was experiencing a similar issue -- I couldn't access an AirPrint printer. By changing the TL-WPA4220's channel width from "Auto" to "20Mhz", the problem appears to be resolved.

0

I had the same problem with the WPA4220, it has been driving me bananas... Turned off IGMP snooping on the router and my bonjour connected printers now work. Wonderful...

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .