3

I had an iPhone 5 before upgrading and its keyboard never froze on iOS 8, but with my iPhone 6 it is happening all the time. I already redefined my keyboard dictionary.

Bringing up console I see a error on TextInput:

Nov 18 11:19:27 GBFGabriel-iPhone-6 com.apple.xpc.launchd[1] (com.apple.TextInput.kbd) <Notice>: Service only ran for 1 seconds. Pushing respawn out by 3 seconds.

Anyone has any idea why is this happening/how to fix this?

3

With a little more digging I found that the problem was with the kbd process using tons of memory when I tried to write something. Google search with "kbd process" bring me a lot of useful links:

iOS & iCloud: Broken iCloud data causes kbd process to crash constantly and drains battery

https://discussions.apple.com/thread/5521035

http://forums.macrumors.com/showthread.php?t=1615584

What did worked for me was turning iCloud drive off and on again.

EDIT: So it turned out I was dumb enough to turn iCloud Drive off and don't turn it on again! Been using it this way for some 2 months.

But I've got the solution! (Mac only) I was digging through my iCloud files at ~/Library/Mobile Documents/ and found that there is a folder with the same name of the evil process.

~/Library/Mobile Documents/com~apple~TextInput

I opened it up and decided to read some files, unzip here, convert plist there (see https://stackoverflow.com/questions/15179410/how-to-open-icloud-cdt-file) and voilá: in just one file, the process kbd tried to insert a word 147 thousand times. This entry was a correction from "mongolao" to "mongolão" (southern Brazilian idiom in Portuguese for a vulgar use of the word "retarded"), ironic. As there were lots of these files, I think with myself that the problem is that somehow the kbd process fell into a loophole, and I decided to delete all the content of the com~apple~TextInput folder.

Waited a few minutes for my mac to upload the changes, turned iCloud Drive off and on again on my iPhone and...... working! If I don't come back here to edit this answer it means this was it! (or I forgot something really stupid again)

Oh, and don't even try to boot up Finder to do this, be a good stackExchange user and only use Terminal. (Pro tip: Yosemite breaks the iCloud folder in Finder)

EDIT 3 (3 months later):

tldr: run the following on your Mac's terminal:

cd ~/Library/Mobile\ Documents/com~apple~TextInput
rm -rf *
| improve this answer | |
  • I had this terrible issue since I enabled iCloud drive. It was really frustrating. I wasn't able to write on device for 1019€ single sentence without interrupting. I also tryed to contact Apple support without any successful help. But your advice solved the problem! Thank you Gabriel! – user112449 Feb 4 '15 at 16:10
  • Updating this history: I've bought an iPhone 6 Plus (awesome device, I shouldn't have bought the iPhone 6) and there it goes: this shit all over again. Thanks old me for this answer. – GBF_Gabriel Apr 7 '15 at 23:25
0

Ok, I manage to open some cdt files in plist format. And I see some translations I've added to my phone. How do you see that your phrase was applied 147´000 times?

What did you delete? I'm afraid to delete the wrong stuff :)

*So, what was the contents of the com~apple~TextInput catalog. I have this exact issue and it's beginning to be frustrating not being able to type more than, say, 5 characters before the keyboard freezes. My contents are the directories Documentsand Dictionaries, where the Dictionaries catalog contains the two folders .baseline and .cdmetadata, files with names like mobile.23489DF9-CD89-... and mobile~9273434-28347..., no extensions here at all. From your comment I expected some .cdt or .zip-files at least. What did you delete? I'm afraid to delete the wrong stuff :) EDIT: sorry, I found the .cdt files*

| improve this answer | |
  • I deleted everything inside com~apple~TextInput, seriously. It's working like a charm ;). I counted the words by using the word counter in TextWrangler (any text editor might have this functionality). – GBF_Gabriel Jan 28 '15 at 15:15

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .