2

The Teac A-H01 requires an audio driver, otherwise the sound becomes watery. Teac hasn't released a driver since Yosemite came out.

Are there any workarounds? It seems like USB external sound is fairly standard, so perhaps there are alternative drivers available?

1

Just pointing out that the latest driver (from April 2014) for the UD-H01 (same for A-H01) still works fine for me with MacOS 10.14.6 on a Macbook Pro from 2015.

It's important to follow TEAC's install guide (updated 2018), i.e. don't forget to enable the kernel extension after the system reboot. Since the CoreAudio driver of MacOS works "somewhat" (for me it works for a few seconds, then sound starts to be messed up) it's easy to think that the TEAC driver is enabled and doesn't work either.

2

I have same issue, contacted Teac support and recieved the following

Thank you for contacting TEAC-Audio.

Our engineering department is currently working on this issue. Please be so kind to check our webpage periodically for further info, or a possible driver update.

Thank you for your understanding.

MfG / Sincere Regards Jürgen Customer Support TEAC-AUDIO Europe Liegnitzerstr. 6 D-82194 Groebenzell / Germany Tel. +49-(0)8142-4208 141

2

I will just copy and edit an answer to a different question but I believe it still applies here:

This problem is probably due to kext signing introduced with OS X 10.10 Yosemite. With it you can't run any unsigned drivers and old one is probably unsigned.

You might try to disable kext signing if you want to use the driver. Make sure you absolutely have to do it and you don't have other options since this change is system wide and system is becoming less secure after that.

In Terminal:

sudo nvram boot-args="kext-dev-mode=1"

And reboot. Then try and report if driver is working.

To go back to kext signing put this in Terminal:

sudo nvram boot-args="kext-dev-mode=0"

And reboot.

P.S. I have become interested in the DAC and now I see it has Optical Input. So other workaround might be just using miniToslink to Toslink (or just normal Toslink cable if your Mac is a Mac Pro)

  • 1
    this works perfectly. thanks! I'm worried optical would be a little more damage-prone (since it's for my "docked" macbook). – tedder42 Dec 29 '14 at 1:49
1
  1. Disconnect your TEAC USB cable.
  2. Go to /System/Library/Extentions, and remove the existing TEAC kext directory, like this: sudo rm -rf TeacUSBAudio.kext
  3. Reboot.
  4. Re-install the driver, called TEAC USB HS Audio KEXT Install Package 273.4.2.pkg at the time of this writing.
  5. Reconnect your TEAC USB cable.
-1

I was experimenting same issue

This work for me... just need some translation with google translate http://teac.jp/product/ud-h01/faqs/

  • Your answer would be more useful to others if you could actually summarize the steps you did in english. – nohillside Dec 27 '14 at 14:38

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .