1

I installed Yosemite on an external 3TB drive. I made a specific 300GB partition on it to hold the system and a second for data. Installation worked fine. However, according to Disk Utility in both Mavericks and Yosemite there is only a little more than 800GB available on the whole disk.

When I run diskutil list; echo; diskutil cs list it says there are no CoreStorage Volumes, but I knew from the Yosemite installation that there is one.

How can I get rid of the CoreStorage Volume even as OS X won't acknowledge there is one? Do I dare to delete and erase the complete drive from Disk Utility in Mavericks? It seems risky as it can't even show me the lost partition space.

Here's the output:

/dev/disk2
#:                       TYPE NAME                    SIZE       IDENTIFIER        
0:      GUID_partition_scheme                        *801.6 GB   disk2
1:                        EFI EFI                     209.7 MB   disk2s1
2:                  Apple_HFS X Drive                 320.1 GB   disk2s2
3:                 Apple_Boot Recovery HD             650.0 MB   disk2s3

No CoreStorage logical volume groups found
1

I ran the command cat /dev/random > /dev/disk2 as user "su" and all partitions are gone now. At first, the available disk space was still only 801GB. After a while it showed up properly in Disk Utility as 3.0TB though and I was able to reformat it. Excellent!

Thanks to Topher Kessler for posting the proper commands in How to fix deep formatting problems with OS X drives!

CoreStorage is great technology. Apple info still leaves a lot to be desired.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .