1

I am having trouble running any third party applications that are not created with pure apple native UI. Example, Google Crome, Firefox and Microsoft Word.

When I try launch one of the applications in question they continually bounce up and down in the Dock without ever launching. I have checked all the file permissions and the preferences to allow apps that are not downloaded from the app store to run, they are all correct.

I have also tried rolling back using time machine to a much older install and reinstalling everything, the applications work for a short time before breaking again.

I have also tried reinstalling all the applications, in addition I reinstalled Java and any other runtime tools that may be causing the problem with no luck. I have also tried the basic tricks like restarting the OS.

It may also be worth noting that when this problem first started happening some of my preferences reverted back to default, example natural scrolling turned back on.

I have looked in the system.log and see the following error repeated over and over again every few seconds, not sure if it is related, could indicate some ownership issues.

Nov 17 09:19:41 azula com.apple.xpc.launchd[1] (org.postfix.master[1434]): Service exited with abnormal code: 1

Nov 17 09:19:41 azula com.apple.xpc.launchd[1] (org.postfix.master): Service only ran for 1 seconds. Pushing respawn out by 9 seconds.

and

Nov 17 09:33:49 azula.staff sharingd[238]: 09:33:49.984 : Starting Handoff advertising

Nov 17 09:33:51 azula.staff sharingd[238]: 09:33:51.984 : Stopping Handoff advertising

I also see this log message when launching Firefox, I don't see any messages when launching other problem applications

Nov 17 09:32:49 azula kernel[0]: firefox (map: 0xffffff8041e393c0) triggered DYLD shared region unnest for map: 0xffffff8041e393c0, region 0x7fff8d800000->0x7fff8da00000. While not abnormal for debuggers, this increases system memory footprint until the target exits.

I am running Yosemite 10.10 (14A389) on a MacBook Pro (Retina, 13-inch, Late 2012)

1

While the three errors you showed are problems, none of them have to do with your current issue. The first one is due to a permissions error on incoming mail. See https://discussions.apple.com/thread/3184945?tstart=0 to fix. The second is just for handoff with iOS devices. It is not something to worry about. The third is an error on an old version of firefox. An update should fix it. It is described more in depth at https://bugzilla.mozilla.org/show_bug.cgi?id=804010

As for the problem itself, I would recommend going into Disk Utility and running a permissions repair. It sounds a lot like the apps got quarantined even though you have it set to allow all applications.

  • Thanks, although the first error is not directly related to the application not opening error, it may indicate system permission or ownership problems. Applying the linked fix stops the errors for a short time, they start to appear again after about 1 min. – Levi Putna Nov 18 '14 at 2:21
  • I have tried running the Disk Utility permission validation and fix, unfortunately it didn't find any permission issues or fix the problem. – Levi Putna Nov 18 '14 at 2:23
  • Just to try to rule out simple problems, can you post all (or part if it is long) of ~/Library/Preferences/com.apple.LaunchServices.plist? – Oantby Dec 10 '14 at 5:39
  • Also, try launching an application from a Terminal and see if it returns an error. Ex. open -a firefox – Oantby Dec 10 '14 at 5:48
0

Try launching the application from the "Applications" folder that can be found in finder. If that doesn't work, create a new user and see if it works on that account.

  • I have tried launching from the application folder with the same result. Logging in as a new user and launching the application seems to work. – Levi Putna Nov 17 '14 at 0:32
  • Okay, for now I would use a new account. Do you happen to have a local apple store? – captaindogfish Nov 17 '14 at 0:33
  • I have an apple store down the road. I have an appointment in two days (they are very busy). – Levi Putna Nov 17 '14 at 0:36
  • Okay great, I would also try this out support.mozilla.org/en-US/kb/… Hope I helped! (I will still help if you continue to have problems) – captaindogfish Nov 17 '14 at 0:38
  • 1
    The guys in the apple store couldn't track down the cause of the problem. The end solution was to format and reinstall os x Yosemite. Not really a fix. – Levi Putna Nov 26 '14 at 5:55

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .