0

I tried to install a new SSD with a higher capacity in the optical bay. But OS X cannot format the SSD. I also tried to swap with an HDD but the same problem occurs with an HDD. Failure format or something like this. The drives have SATA III, I checked Mac info. Intel 6 series chipset with 6GB for both HDD and optical bay interfaces which means SATA III (?). When I format the HDD through USB I can write to it via SATA, but Disk Utility suggest repairing. If I check this drive, Disk Utility cannot repair this drive.

How to resolve this problem?

Macbook Pro 13", late 2011

I tried to repartition in two parts. The partitions are created, but before it is complete, and names are assigned to the partitions, Disk Utility fails.

Intel 320 series works without problems in OptiBay, but it has SATA 2, so looks like a SATA problem.

  • what is your exact model number ? – Ruskes Nov 16 '14 at 21:33
  • Model number is MacBookPro8,1 – Sonique Nov 16 '14 at 21:59
  • Thanks, AFIK it does support SATA 3. But some SSD manufacture have problem firmware, so a full safe erase is recommended, or try getting updated software from OEM. Who is the Manufacturer of the SSD? – Ruskes Nov 16 '14 at 22:23
  • It's Intel 540 240gb, I will try update and erase, but hitachi travelstar 7k1000 hdd also not works. – Sonique Nov 16 '14 at 22:26
  • So were you able to solve the problem of formatting the SSD drive via SATA on optical bay? I tried to do the same thing, inserting a 240GB SSD in the optical bay, but I can't format it giving error "Partition failed: wiping volume data to prevent future accidental probing failed", but the fact is, there was no partition there, no data, completely new drive. – Sean Lee Apr 29 '15 at 21:24
1

Have just faced a similar problem with MacBook Pro (17-inch, Early 2011) and SSD installed into the Optibay. Operating system: macOS 10.12.3 (16D32).

«Disk Utility» got stuck on the «Waiting for partitions to activate» phase of the erasing process.

The solution, which worked for me, was to put the SSD into the main bay and the HDD into the Optibay.

0

As of Nov. 2. 2014 there is a report regrading that problem.

http://www.larryjordan.biz/caution-ssd-drives-and-yosemite/

If you own a 3rd-party SSD (Solid State Drive) unit and plan to upgrade to Yosemite – you NEED to read this.

The issue revolves around Trim utility software used by the SSD drive.

For possible fix read here.

http://www.cindori.org/Trim-enabler-and-yosemite/

http://blog.macsales.com/21641-with-an-owc-ssd-theres-no-need-for-Trim

In OS X 10.10 (Yosemite), Apple has introduced a new security requirement called kext signing. (A kext is a kernel extension, or a driver, in Mac OS X.)

“Kext signing basically works by checking if all the drivers in the system are unaltered by a third party, or approved by Apple. If they have been modified, Yosemite will no longer load the driver. This is a means of enforcing security, but also a way for Apple to control what hardware that third party developers can release OS X support for.

  • This does not appear to relate to the OP's question. If TRIM was the problem, the computer wouldn't even boot because of kext signing. – oarfish Nov 17 '14 at 18:16
  • Hi, I think problem not in Trim support, disk not works properly with OptiBay sata. I have intel 320, intel 540 for upgrade and travelstar for data store. Intel 320 works in optibay, others not, so travelstar not ssd but also have such problem. – Sonique Nov 18 '14 at 8:57
0

erase / format the SSD while still outside and connected via usb (sata to usb cable): GUID Partition table, Mac OS Extended (journaled). When you want to use the SSD as startup disk: use CarbonCopyCloner or SuperDuper to put a clone of the actual StartupDisk, when still outside, then swap with the HDD. Do not use Trim, some SSD controllers are not handling it very well.

-1

There was a firmware update for late model 13" MacBook Pros, possibly just the 2012, that properly enabled the SATA 3 in the optibay. In all other (non Retina) MBPs it's safest to use only SATA 2 drives for stability in the optibay, even though they report as SATA 3. Your HDD should have worked in the optibay, but may have been faulty, unless it was SATA 3. Search the OWC blogs for the many articles regarding the optibay issue.

-1

Intel datasheet for intel 540 ssd does not list macos as a supported op sys

Some of the information contained in this post requires additional references. Please edit to add citations to reliable sources that support the assertions made here. Unsourced material may be disputed or deleted.

  • Welcome to Ask Different. We like answers to be more than just a single line. Ideally, you want to explain why your answer is *right." It also helps to provide links, citations, and/or screen shots. Please review our help section How to Answer on writing good answers to questions – Allan Oct 7 '16 at 1:14

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .