4

I've done my research and found some really ancient questions, including this one, Always Asked to Configure Firewall for iTunes, where the firewall on OS X asks to allow incoming internet connections every time I launch an app that is internet connected.

This has only happened since I upgraded to yosemite. This is also doing the same for apps like steam that need to use accessibility features for in game overlays.

I've tried several fixes, including re-installing apps, to no avail.

It seems that since the yosemite upgrade, it just doesn't seem to store preference information, like it's stuck in a certain state and nothing will override it.

Any help out there please as it's becoming quite an annoyance!

1

Sadly, adding the permission to the Firewall preference pane doesn't work. It may work for one launch, but the problem returns when you quit and launch it again. OS X doesn't like unsigned apps and will ignore your preferences for your own protection. I had the same problem with Kodi and the only way around it was to sign the application yourself using the shell command prompt.

sudo codesign --force --sign - /Applications/Steam.app/ 

You will then have to OK it once to allow a connection, but it will then stop nagging you finally.

0

If you turn on the firewall in OSX (Yosemite and El Capitan at least) by default the "Automatically allow signed software to receive incoming connections" option is ticked. Any software that is not signed will require confirmation each time it is launched to allow it to receive incoming connections.

You can check whether a piece of software is signed by running the following command against it in a Terminal window. For example...

codesign -vvv /Applications/Steam.app

When I run this against Steam on my iMac I get the following response. This is why I have to tick the "Allow incoming connections" box for Steam at each launch.

/Applications/Steam.app: resource envelope is obsolete (custom omit rules)

However you can allow an unsigned application to permanently be allowed by adding it to the going into the "Firewall Options..." in the Firewall pane of the Security & Privacy System Preferences pane. From Apple's KB article OS X: About the application firewall:

To allow a specific app to receive incoming connections, add it using Firewall Options:

  1. Open System Preferences.
  2. Click the Security or Security & Privacy icon.
  3. Select the Firewall tab.
  4. Click the lock icon in the preference pane, then enter an administrator name and password.
  5. Click the Firewall Options button
  6. Click the Add Application (+) button.
  7. Select the app you want to allow incoming connection privileges for.
  8. Click Add.
  9. Click OK.

Screenshot of Firewall Options... dialog with Steam allowed

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .