5

While on OS X 10.9 it works nice to switch windows of all apps (not produced by apple) I am using in my work like Google Chrome, SublimeText, iTerm from keyboard using:

cmd ⌘ + `

On OS X 10.10 it works only with apple apps ;(

Is there something changed, what third-party applications developers should change, or is some other keyboard shortcut to get this working as it should?

UPDATE: - I restored all keyboard settings to default, and things started working as expected.

enter image description here

Make sure that this one checkbox is checked:

5
  • Cmd + ~ is still working in Yosemite to switch windows in non-Apple apps for me.
    – tubedogg
    Nov 15, 2014 at 23:39
  • 2
    The key combination is cmd - ` rather than cmd - ~. Perhaps on your keyboard these symbols are not on the same key?
    – amergin
    Nov 15, 2014 at 23:43
  • @amergin Indeed my mistake, I meant of course ` and not ~. But this still does not work for me on non-apple apps ;(
    – andilabs
    Nov 15, 2014 at 23:49
  • This does not work for me. Which keyboard layout are you using?
    – d-b
    Jan 15, 2015 at 7:41
  • EDIT It actually works but I had to press ⌘⇧ and the key next to backspace on my Swedish keyboard. Without ⇧ I get the ´ acute accent, not ` grave accent (or "backtick" as illiterates call it).
    – d-b
    Jan 15, 2015 at 7:52

7 Answers 7

8

It seems not to work in full screen mode of apps. Switching to normal mode everything works fine.

3

I had to uncheck "Move focus to next window", then recheck it. Then it started working.

1

Go to system preferences/keyboard/shortcuts/keyboard and then check box to the left of "Move focus to next window' [command `]

Before I checked box, there was no keyboard shortcut to cycle between open windows or tabs on Chrome, Safari, and Firefox.

After checking box, command` cycles between open windows/tabs in all browsers

1
  • 1
    Thank you! Mine was mapped to ⌘ F1 and I never set it to that. It must be something to do with region settings. Japanese region settings here on a US keyboard. (And previously used a Japanese keyboard)
    – Mentalist
    Apr 24, 2017 at 6:07
1

For MacBook Pro, the default settings are: Cmd+`

But to access this shortcut from the keyboard, you need to press: Cmd+Shift+`

This looks difficult as you need to press three keys together. So a better option would be to Go to System Settings > Keyboard > Keyboard Shortcuts > Keyboard, and change the key combination for Move focus to next window to Cmd+@ and enable the checkbox.

It started working

Keyboard Settings settings to reset 'Move focus to next window' command

0

I've bought a Macbook Pro with german keyboard a couple of weeks ago. It came with Yosemite installed, I was looking for the same shortcut, I found that Cmd + < does the trick.

1
  • That seems to open settings on mine (standard keyboard)
    – Ankur
    Jul 8, 2015 at 17:11
0

A slightly different thing solved it for me. The checkbox was checked and the shortcut was ⌘ F1 but it wasn't working. Changed the shortcut to a different one and it worked.

0

I had a similar issue when Stage Manager was on. Sometimes Cmd+` worked, sometimes not. After disabling Stage Manager, the combination works perfectly.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .