1

I wanted to have dual-boot setup on my MacBook Pro. So after searching for a bit, I found a couple of sites that offered a step-by-step explanation on how to do it using rEFInd.

I successfully installed it - I got the rEFInd startup screen and everything. The problem is that when I selected the USB drive I wanted to install from. It always got stuck on a black screen saying

No bootable device -- insert boot disk and press any key

But that’s a different problem. After not being successful in booting from the USB drive, I had a “brilliant” idea.

I could take the same image I flashed onto the USB drive and try to do the same but on the partition I had prepared for Linux, so then maybe rEFInd will be able to boot if it’s on the hard drive. So I did the following:

sudo dd if=/path/to/downloaded.img of=/dev/rdiskN bs=1m

With diskN being the partition on the hard drive, then restarted. And after that, the MacBook Pro never came back. It makes the chime sound, and that’s it. Also, I notice that Caps Lock and Eject keys don’t work, as I tried booting from a Linux CD and now I cannot eject it.

Startup key combinations don’t work, so using the recovery partition is not an option. It only turns on, makes the chime sound and get’s stuck on a white or grayish screen.

Any advice on how to solve this or ideas on what could have happened?

  • That's about the point at which I'd be looking for another HD to put in, so you can work on a disposable until you can fix the important one. – Tetsujin Nov 15 '14 at 18:26
  • Thanks for the advice. Luckily I have my work macbook, so I can use that in the meantime and try to fix that HD with it. I was just trying my luck, in case someone had an easy solution – user3198877 Nov 15 '14 at 18:32
  • I think it would be wise - I don't know the solution to your issue, but that would at least give you a sound, danger-free base to start investigating from. – Tetsujin Nov 15 '14 at 18:34
  • none of pram/smc reset/internet recovery mode work? All keys are dead except power on/off? – klanomath Nov 15 '14 at 18:46
  • Thanks for your suggestion @klanomath. I tried the pram reset and that worked, in the sense that it rebooted as they said it would, but the laptop remained the same.Cannot do network recovery as it doesn't respond to cmd+R and after the smc reset it also statys the same – user3198877 Nov 15 '14 at 18:50
1

After reading the comments I would try to use Internet Recovery (Command + Option + R) and see if that works.

  • Thanks for your reply. Unfortunately it doesn't respond to that combination either – user3198877 Nov 15 '14 at 19:04
  • Sounds like you may have an issue with the computer firmware then. If that is the case there is very little you can do. What kind of model MacBook Pro do you have? – ProfFrnswrth Nov 15 '14 at 19:08
  • Thanks.That would be really bad. It's a Macbook pro 13 inch late 2011. But I don't understand how my actions could've led to corrupt the firmware. – user3198877 Nov 15 '14 at 19:12
  • Hmm your computer doesnt support the Firmware Restoration CD so the only other option I can think of is to use another Mac. Download OS X Lion or later and create a bootable USB of it and try to boot to it. Then you could use Disk Utility to repartiton your HDD and see if that fixes it. Or if all else fails you could bring it to the Apple Store and see what they could do, but they may charge you. I would check – ProfFrnswrth Nov 15 '14 at 19:29
1

What worked for me was that I got a USB enclosure, formatted the “Linux” partition, uninstalled rEFInd with this command:

sudo rm -r /EFI/refind

And everything came back to normal.

  • Why the down vote? The user solved the issue they inadvertently created and did so in a way that makes sense as an answer for anyone else who comes across a similar situation. – JakeGould Nov 16 '14 at 23:15

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .