Whenever I start Safari 8.0 (on Yosemite 10.10) after resuming my Mac from sleep, it kicks off a web process which consumes 100% CPU and soon gets the fans on my MBA going:

safari web process at 100% cpu

What's strange is that it's always the same URL (http://www.saudecuf.pt/) which is a site I haven't visited for a very long time, certainly not since I upgraded to 10.10. I have no idea why it's picking up that URL. The only solution is to force quit that process and from then on Safari behaves normally until the next time I put my Mac to sleep.

Very frustrating.

BTW: the site is the site of a local private hospital, nothing special.

  • btw, the figure of 100% can be misleading. The figure should be divided by the number of cores, so a 4-core would be 25% actual, 8-core 12.5%. I don't know if hyper-threading affects that, I don't have a hyper-threaded machine here, just 8 actual cores.
    – Tetsujin
    Nov 15, 2014 at 17:04
  • @Tetsujin yes, I'm aware of that. However, regardless of what actual cpu usage is going on, it's enough to slow down my MacBook Air and get the fans going, so it's a problem.
    – mluisbrown
    Nov 15, 2014 at 22:19
  • Hopefully there are enough answers to get you started on a solution. As you can see, lots of people have similar experiences, so without more details it will be hard to know if this is due to a specific bug - a specific web site code - caching from Safari (of top sites and or history) or even Spotlight looking for search suggestions. With some more specific details, we could reopen this.
    – bmike
    Jul 7, 2015 at 22:03

5 Answers 5


Sorry it's not a solution, but just to reassure you that you're not going mad: I have the exact same problem, different URL, but similarly old and unvisited - it's not even an open tab or within top-sites.

However, as well as peaking at 98% CPU usage, I also eventually get the red error notice in Activity Monitor 'Safari Web content (not responding)' and everything slows down - although Safari is mostly still usable.

I've tried disabling extensions and iCloud sync. Even restarting doesn't remove the old URL.


The only solutions I've found is to turn off the Favorites page. This seems to be related to the favorites page hanging up while trying to build itself.

Go into Safari Preferences. General tab.

Change the following. New windows open with: Empty Page New tab opens with: Empty Page

Solved it for me but annoying if you use the Favorites Page.


I had the same issue, start Safari, no open windows, at 100% of CPU.

The way to solve this was:

  1. Close Safari
  2. Go to ~/Library/Safari/
  3. Remove all files from there
  4. Open Safari, and wait for iCloud sync (all my bookmarks and stuff)

And done! My Safari was back to normal.


I've just had a similar issue with all open tabs jointly consuming 100% of the CPU, no matter how many or few I had open. Other processes were barely getting a look in, and Safari was still completely unusable. Closing & opening pages, relaunches and restarts didn't help.

I ran AdwareMedic. It found and facilitated removal of some scummy malware that had wormed its way in to Safari. This immediately resolved the problem.

Clearly these plugin writers are not the finest of software engineers – the thing would probably have gone unnoticed if it hadn't made my system and Safari hopelessly unresponsive.

I expect my son inadvertently installed it while trying to find interesting Minecraft plugins. Unfortunately the sites hosting them are stuffed full of malware downloads.

Worth a look, I reckon. Adwaremedic is donation ware.


When this happens, you can gather detailed logs and submit it to Apple for a bug fix or for specific support if you wish.

Open Activity Monitor, select Safari and then use the gear to "Run System Diagnostic" on the safari process.

This will make a comprehensive system snapshot that you can pick apart if you wish or keep it around until you have 10 instances and can then see if there's a pattern to the high CPU usage.

Not the answer you're looking for? Browse other questions tagged .