1

I have an SSD in my MacBook (Pro 9,2; encrypted), and until recently, the apple icon appeared almost immediately after pressing the power button. Soon after that I would be able to unlock the disk using my password and then boot in ~10 seconds. A couple of days ago, I installed rEFInd on a flash drive and then booted from it as a test (I need the stick to boot into Ubuntu on my second drive and was in the process of reinstalling it). I was then in the rEFInd menu and chose one of the tiles (I think it was "Boot Linux from 16GiB FAT volume" or something like that). Naturally, since no Linux was actually installed, I was met by the black screen with the blinking cursor and powered the computer off by long-pressing the power button.

Ever since then, it takes almost 20 seconds for the Apple logo to appear after power on, even though the rEFInd stick is not connected. This triples my boot time and I see no reason why it should be so, since I did not change anything on the SSD.

Edit: The process can be shortened by pressing ALT at boot, then manually selecting the SSD, after which booting will begin immediately.

Can anybody tell me a) how to diagnose the problem and b) how to fix it?

1

Turns out resetting PRAM and NVRAM via pressing ++P+R at boot (before the gray screen appears; hold until computer restarts and the startup chime has been heard twice) fixes the problem.

I have since successfully booted both OSX and Ubuntu via rEFInd without any excessive waiting.

  • Can confirm the efficacy. Thr problem started happening for me after a logic board replacement, but this fixed it. – JJJollyjim Apr 18 '15 at 7:21
0

I had this happen with rEFInd before. I think rEFInd boatloader ended up in your efi partition. The excruciating long wait is rEFInd checking every device/partition to see if it's bootable.

I have the debug menu in disk utility enabled, so I just selected show all partitions, mounted the efi partition from available partitions in the top left window, and removed rEFInd's .efi file. I also emptied the trash just to be sure.

To enable disk utility debug menu open terminal and run "defaults write com.apple.DiskUtility DUDebugMenuEnabled 1". rEFInd should have is own folder, so not delete anything from the apple folder or anything else for that matter. Unmount efi partition when finished.

Hope this helps.

  • I have the debug option set, but the EFI partition only appears when running diskutil list, not in the Disk Utility GUI. I mounted it via command line, and strangely, there's folder called 'ubuntu' on it, which appears to contain Grub or something related to it. How did that end up there? Also I did not install rEFInd on any disk, so it does not run at startup (else I would see the rEFInd menu at some point, right?). – oarfish Nov 16 '14 at 8:40
  • I've had the delay even when the menu did not appear. Did you find the rEFInd boot loader ? – Brian Duke Nov 16 '14 at 11:56
  • No, only the ubuntu folder. I couldn't find a trace of rEFInd on any partition. I also checked the EFI partition on my second drive (HDD) – don't even know why it's there, maybe leftover from when I moved my OS to the SSD – but no, nothing. – oarfish Nov 16 '14 at 12:32
  • @oarfish weird, maybe your problems different from mine. Do you have file vault turned on, if not sometimes there's a boot folder on the os x partition, I believe that is where rEFInd installs by default, I can't remember the path off the top of my head, but if you have FDE then its irrelevant. – Brian Duke Nov 16 '14 at 15:47
  • Yeah, FileVault is on, but I only ever installed rEFInd on the usb (./install.sh --ownhfs /dev/disk3) and that worked so it would be very weird if it had also installed itself on the SSD somewhere. – oarfish Nov 16 '14 at 15:58

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .