0

I've been searching for a while to figure out a way to get Safari to keep loading (buffering) paused videos when the tab containing the video isn't the one I'm currently focused on.

If I go to another tab in Safari to read something while the video loads, the video stops loading. But also if I leave the tab in the front and go to another application to do something while the video is loading the video stops loading.

This definitely happens every time when I'm dealing with Vimeo. I think it happens other times, but I can't think of any places to try out. I don't use flash player, so this might only be happening with html5 video players.

I found a page that promised to help with loading background tabs, but it relates to Lion (I'm on Yosemite) and the person seems to be saying that tabs don't load at all in the background. I'm not having that problem (and unsurprisingly the solution didn't work).

  • Loading means continue playing or what ? just tried it on Firefox with Vimeo video and it keeps running. – Ruskes Nov 14 '14 at 20:21
  • Just tired it on Safari with Vimeo playing video, and switching to another tab does not stop the play. – Ruskes Nov 14 '14 at 20:24
  • if I pause it it stops, so what is the point. – Ruskes Nov 14 '14 at 21:06
  • If I do not stop the play, and switch to another tab it continues to play. If I stop the play it stops. – Ruskes Nov 14 '14 at 21:13
  • Let us continue this discussion in chat. – dwightk Nov 14 '14 at 21:25
1

I think the setting you’re looking for is Disable Hidden Page Timer Throttling, located under DebugMiscellaneous Flags.

If you haven’t enabled the Safari Debug menu yet, triple-click the following line and paste it into a Terminal session:
defaults write com.apple.Safari IncludeInternalDebugMenu 1

Now completely quit Safari, then reopen it. The Debug menu should become available.

If you’re on Safari Technology Preview, the Terminal command is:
defaults write com.apple.SafariTechnologyPreview IncludeInternalDebugMenu 1

  • I also had to Disable App Nap and restart Safari for PiP to work with Safari in the background (or in another space). – Bruce Alderson May 3 '18 at 18:09
0

Just go click on "Preferences" in Safari menu. Then, in "Advanced" tab, uncheck the thing about plugins in background. Good luck

  • "Stop Plugins to save power"? – dwightk Feb 26 '15 at 23:36
  • this doesn't work – dwightk Jan 19 '17 at 18:00

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .