3

I'm using Mail client that's built-in into the system (Yosemite). I've decided that I want to use CTRL+V, CTRL+C and similar instead of CMD because I work half of the day with Windows and it's impossible for me to easily switch off my habits every half a day. I've considered 2 options:

  • final switch between CTRL and CMD which had a lot of consequences that I didn't wanted to tackle
  • switching on Shorcuts option available at System Preferences -> Keyboard -> Shortcuts and adding here any "special" shortcuts on per app basis.

I've used 2nd option. This generally works fine. I've added things like Copy, Cut, Undo Paste and so on mostly mimicking what I have on my Windows machines. And everything seems to be working fine except one small detail "CTRL+V" paste. It only works as a PASTE until the email I'm creating fits on page. When there's a lot of text.. the CTRL+V becomes Page Down button. It's like CTRL+V in the Mail app is hardcoded to be Page Down and the shorcuts seems to be working fine until CTRL+V is able to actually behave as Page Down then it stops working.

How do I disable Page Down (CTRL+V) behaviour as described above?

  • 3
    It's easier to get used to the distinction than try to fight it, long-term. – Tetsujin Nov 13 '14 at 16:48
  • Instead of using key strokes, cut, copy & paste can also be executed from the Edit menu. – IconDaemon Nov 13 '14 at 16:53
  • I switch daily between Linux and Mac. Trust me, it is the completely opposite of impossible to switch. I rarely make a mistake – Mathias711 Nov 13 '14 at 17:45
  • I am not fighting. I just want to use what I want to use. I have virtual machines on mac and those use ctrl+c/v an then mac uses cmd+c. Then another computer next to me users ctrl+c. I switch a lot between different systems. I want things to work my way. It seems like a bug to me in Mail.app. – MadBoy Nov 13 '14 at 20:59
  • Control+V is no bug; it's an Emacs and general UNIX shortcut for page down. Apple implemented it so you can navigate text easily. (here's a list of all shortcuts) – 0942v8653 Nov 13 '14 at 22:42
2

There's a much easier and more effective way to do this: go to System Preferences > Keyboard > Keyboard tab and click the "Modifier Keys..." button.

From there, you can set the Control key to behave like the Command key:

enter image description here

| improve this answer | |
  • I've already mentioned in my main post I don't want to do that. This changes behaviour of so many things it's not an option for me. – MadBoy Nov 14 '14 at 8:18
2

Karabiner

This will do exactly what you're looking for, I think this is the setting you're looking for too.

enter image description here

| improve this answer | |
  • I got used to CMD +V although I do get some frustrations from time to time when things don't go as planned. – MadBoy Mar 4 '16 at 14:13
2

I run into same issue: At work I have to use Windows and at home I use a Mac. I'm sick of having different shortcuts for these basic tasks. Here is my solution for it:

Go to your User folder on your Mac and open the Library directory.

Here you create a "KeyBindings" folder.

Then navigate into that folder: (Your User folder)/Library/KeyBindings/

Create a file "DefaultKeyBinding.dict" with following lines:

"^v" = "paste:";
"^c" = "copy:";
"^x" = "cut:";
"^z" = "undo:";

Save everything and restart your Mac.

Now, you will have CTRL + x/c/v/z working like it is on a Windows machine.

This will change the behaviour for page down as requested by MadBoy.

| improve this answer | |
1

Create or edit the file: ~/Library/KeyBindings/DefaultKeyBinding.Dict (may need to create the folders as well) to contain the text:

{"^v" = noop:;}

You will then need to close and re-open the programs that you were have problems with.

| improve this answer | |

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .