8

Since updating to Yosemite, whenever I plug headphones into my MBP, it selects Soundflower as the default output device. I then have to manually change it everytime. Anyone know why this is happening, or how to fix it? Also, I can't get rid of Soundflower for some reason.

5

First of all, I'll address the how to uninstall Soundflower problem:

A number of people have run into problems uninstalling it in the past. The main problem seems to be that you have to reboot your machine after running the uninstaller but if that doesn't work for you try removing it from the Audio MIDI setup.

Open Audio MIDI Setup in the utilities folder and look for Soundflower listed there, select it and click the minus near the bottom left to remove it.


Now that you've removed Soundflower, you need to set the headphones as your default output device:

  1. Connect your headphones
  2. Open System Preferences and Open the "Sound" panel
  3. Go to the "Output" tab
  4. Select your headphones here
  5. Close system preferences

Your system should now default to the headphones whenever you plug them in.


If you run into further problems, you can try a couple of advanced steps:

  1. Open Finder and in the "Go" menu, select "Go to Folder..."
  2. Type ~/Library/Preferences and click Go
  3. Locate two files called com.apple.systempreferences.plist and com.apple.audio.AudioMIDISetup.plist and move them both to the trash
  4. Reboot your computer
  5. If you're still having problems reset PRAM by rebooting again and holding command-option-p-r as soon as your computer boots up, keep holding until your computer restarts again and you hear the startup chime.

Follow all the above steps from the beginning of this post and one of them should solve your problem, make sure you check each time if your headphones are now working by default.

2
+50

Uninstall Soundflower. There should be an uninstaller located at:

/Applications/Soundflower/Uninstall Soundflower.scpt

Run it, enter your password, and reboot (very important). If it's not there, upgrade Soundflower first here.

EDIT: You can set your default audo device by going to /Applications/Utilities and opening Audio MIDI Setup. Select the device you want to use, click the gear, and then Use this device for sound output.

Audio MIDI Setup Use this device for sound output

  • 1
    I'd prefer to learn how to permanently set the default audio output device. I have a couple of other output devices that I do occasionally use that I don't want to uninstall. – Kevin - Reinstate Monica Jan 13 '15 at 0:00
  • @Kevin I updated my answer. – Coder-256 Jan 13 '15 at 0:18
  • 1
    Sorry I took a while to give you the bounty. Thanks for your help! – Kevin - Reinstate Monica Jan 19 '15 at 23:10
0

Restart the computer, select the output device you want, restart again, then look in System Preferences again to see if it saved as the setting you previously had.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .