6

How do I permanently stop iPhone text messages from appearing on my iMac. I don't want to send/receive/view messages on my computer. I only want to use my phone for sending/receiving/viewing messages. Also, I'm hoping the fix doesn't require constant maintenance. I've gotten advice for this before, but the fix has to be repeated every time I restart my computer.

6

To disable Text Message Forwarding:

  1. On your iPhone, open the Settings app, then tap on Messages, then Text Message Forwarding.
  2. Tap on the on/off button across from your Mac's name to disable.
  • I find it disturbing to see that in my case this option is not selected, and never had been, and that if I had it was supposed to be something I would've approved with a passcode. Lovely... – Josh Sutterfield Jun 1 '15 at 19:57
  • This answer is specifically regarding SMS forwarding. IMessages are always sent to both places, assuming you are signed into the same Apple ID on each device/computer. – tubedogg Jun 1 '15 at 19:59
4

If you specifically mean iMessage, rather than SMS forwarding, then ...

  • Launch Messages on the Mac
  • Messages menu > Preferences > Accounts > [Settings] > Sign out
  • Thank you for the informaton but the "Preference" tab is located under the "Message" heading & not the "File" heading. – user103118 Dec 2 '14 at 16:51
  • oops, so it is. Fixed. – Tetsujin Dec 2 '14 at 18:00
  • I find it disturbing that the top answer suggests the opposite, which is that it requires something be initiated from the iPhone requiring a passcode. But all I had to do was use the same apple ID and it's already doing it, and I have to disable it from the macbook indeed. So it's intercepting SMS from my cell carrier on systems I didn't specifically approve for doing that. And the phone itself indicates that it would not allow such a thing. Lovely – Josh Sutterfield Jun 1 '15 at 20:04
  • tubedogg's answer is specifically for SMS, mine is for iMessage - they are 2 different things. Lots of info at support.apple.com/en-us/HT204681 – Tetsujin Jun 1 '15 at 20:22

You must log in to answer this question.

protected by Community Jan 3 '15 at 13:13

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged .