3

I have the newest Pages 4.3 and Yosemite 10.10 so the report makes no sense, Pages has been messed up. I tested the conversion between pages file and zip and it recompiled pages to a folder but it did not work -- only getting the error: you need the new Pages.

How can I fix this I-Cannot-Open-Any-Pages-File-On-My-Computer-Anymore with Pages?

enter image description here

enter image description here

5

You need to go to the Mac App Store and install the latest version of Pages (5.x)

As of now, the latest version of Pages is 5.5.1, and it's only available from the App Store.

Pages About Box

I've seen this when using Pages from iWork '09, which is 4.3. The file format changed and iWork '09 cannot directly open the new files.

You can export iWork '09 compatible files from Pages 5.x though.

  • I have two Pages in my computer 4.3 and 5.5.1, how can I remove the old one? I have bought it from Mac Store OSX thing. It somehow messes up the versions: for some reason using all the time 4.3 unless opening it through Mac Store, odd! – hhh Nov 12 '14 at 22:44
  • 1
    @hhh On my computer, those are in Applications / iWork '09 and I've removed the whole folder of older apps. – Geoff Hutchison Nov 12 '14 at 23:17
  • Accepted because of the comment, now Pages opens the newest Pages -- for some reason, it opened all the time the old Pages program. – hhh Nov 12 '14 at 23:38
  • 1
    LaunchSystems, the part of Mac OS X that determines which app to open is sometimes very strange. Glad it works for you now. :-) – Geoff Hutchison Nov 13 '14 at 2:58
1

Being that I have frustrated no end by this ridiculous message with NO solution (that I could find) from Apple, here is what I finally stumbled on.

After a recent "re-start" I could not open some documents. Always got the "xml" message.

Tried all sorts of things. Updated to Yosemite - wouldn't run. TRIED to update Pages to 5,x (had 4.x before) - no dice. Then Yosemite finally updated. Pages ? I got the "installing" message but that NEVER ended.

After more frustration, I finally found a particular document I had had on my "startup: list that was PASSWORD protected. For whatever reason, on re-start, the password protected file didn't come up.

So, finding THAT doc in my pages list, I clicked on it and the password box came up. I entered the password and the document appeared. Once I did that the other docs that previously got the "xml" message appeared as well. And finally, I find that I DO HAVE Pages 5.x installed after all (Only Pages 4.x was showing before.

Note - for about a week or 10 days now something (automatic update ?) has changed in my MAC. When I click on say "Pages" (in the dock) my Chrome browser slides to the right instead of simply staying in the background. My menu bar also "hides" where before it stayed at the top. I cannot find any "fixes" for these.

1

Interesting observation: I've been seeing the "File Couldn't be Opened / The required index.xml file is missing" dialog when I attempt to open several numbers documents. At the same time, the App Store was downloading updates to Xcode; however, the download appeared to stop. I disconnected the network and was able to halt the download. After that, I was able to successfully open up the documents using numbers...

1

Today, I tried to open Numbers documents and, for no known reason, received the message the documents were invalid because the required "index.xml file was missing. After an hour of panic and knowledge-less button pressing,I shut my MacBook Pro down completely, let it rest for about 10 minutes.

After starting back up, the problem disappeared and all numbers documents opened without error messages. Have no idea what or why?

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .