4

Since upgrading to Yosemite, I can't enter a New Event in Calendar using the 24 hour clock. If I try to enter the start or end time as 14:00, it enters the 1 and then beeps at me.

Calendar does display events in 24 hour format, I just can't create a new event using it. I've check the calendar and Mac settings and they all appear correct.

  • 24 h as AM/PM or European stile ? – Ruskes Nov 12 '14 at 20:08
  • hh:mm, for example 01:23 for 1:23am or 13:23 for 1:23pm – Jennifer Nichole Johnson Nov 12 '14 at 20:26
4

I do not have Yosemite but on Mavericks you can set it up as follows:

Open system preferences Languages and Regions

Click on the 24 Hour time format.

That should change the time format in Calender.

time

I can enter any time (as 2 digits)

Let me know if it works in Yosemite.

  • 1
    smacks forehead Thanks. That worked.My clock displayed it correctly and I swore I checked all the settings. It worked in Mavericks and stopped working when I upgraded to Yosemite. I have no idea what changed. – Jennifer Nichole Johnson Nov 12 '14 at 20:34
  • Don't smack your self, just accept the answer and move on :) – Ruskes Nov 12 '14 at 20:37
0

There does seem to be a problem here. My computer was showing a 12 hour clock plus am or pm. Changing this to 24 hour clock in the date and time section of system preferences didn't work. After some digging I found that the language and region section of system preferences also has a 24 hour clock setting option. And this one works. Looks like a little buglet for Apple to fix

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .