0

I tried using lp to print to our HPLazerJet P1102w from the command line. Items were added to the queue, as returned by lpq:

macbookpro1:~ mikekilmer$ lpq
HP_LaserJet_Professional_P_1102w is ready
Rank    Owner   Job     File(s)                         Total Size
1st     mikekil 26      (stdin)                         0 bytes

But the OS seems to think the printer is set on manual feed. Now the printer utility returns: "unable to communicate with the printer at this time."

lpstat returns:

HP_LaserJet_Professional_P_1102w-26 mikekilmer           0   Wed Nov 12 10:05:13 2014

And it seems maybe I need to add a user to the ip and sys groups.

hp-toolbox and hp-setup both return command not found and I'm not even sure what I would do with them if they worked.

Based on macbookpro1:~ mikekilmer$ cat /etc/group | grep lp, thinking the relevant groups would be:

_lp:*:26:
_lpadmin:*:98:
_lpoperator:*:100:

Also read that:

"This can also be caused by printers such as the P1102 that provide a virtual CD-ROM drive for MS Windows drivers. The lp dev appears and then disappears. In that case, try the usb-modeswitch and usb-modeswitch-data packages, that lets one switch off the "Smart Drive" (udev rules included in said packages).

This can also occur with network attached printers if the avahi-daemon is not running. Another possibility is the specification of the printer's IP address in hp-setup fails to locate the printer because the IP address of the the printer changed due to DHCP. If this is the case, consider adding a DHCP reservation for the printer in the DHCP server's configuration. "

But I'm not really sure what any of that means. I could, of course delete and reinstall the printer, but would like to get more of an idea about being able to configure it properly so that command line printing can work along with GUI methods.

1

Interesting,

I do have the HP LaserJet Professional P1102w as well as a network printer (WiFi) shared between Mac and Windows computers.

The Driver version is 2.0

I do not use any of the HP stuff like "hp-toolbox and hp-setup".

lpq 

results in

HP_LaserJet_Professional_P1102w is ready

no entries

The lpr fileName works just fine.

In your case try to cancel any pending jobs with lprm job-id

Considering it was a low cost ($150) printer it works like charm.

I know that I am not specifically answering your question, but just sharing information that might help you.

  • Thanks, man. I may not actually find an answer, because I noticed that computer had at some point in the troubleshooting process, connected to the wireless network of the printer itself. When I reconnected to the local wifi, not only did printing work, but it worked wirelessly for the first time. However, would you mind telling me where one retrieves the info from your screen capture above? – MikeiLL Nov 12 '14 at 20:30
  • 1
    from the printers web page- Network Summary! – Ruskes Nov 12 '14 at 20:35

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .