4

I use my mac (yosemite 10.10) at work with bluetooth mouse and at home with just the trackpad. Whenever I bring my mac back to work and start it up, >90% of the times it can't find the mouse. Turning bluetooth on/off, trying trickery with turning mouse on and off and all that doesn't work. Restarting blued didn't work. Removing mouse from bluetooth settings and trying to re-pair didn't work (could not find the mouse). Changing the batteries didn't help. The only thing that works, is rebooting the mac. After this everything works as it should.

I find this not to be the correct solution. I mean this can't be a hardware fault, can it? And if not, resetting/restarting some piece of software should do the same trick as rebooting the mac.

My mouse is apple magic mouse. I have no bluetooth keyboard.

1
  • Do you know how to provide Console log for the time stamp of interest -after it wakes up and some 50 lines after that ? so we can look what is it doing !
    – Ruskes
    Nov 12 '14 at 7:44
6

I've had issues reconnecting my bluetooth keyboard & trackpad since upgrading to Yosimite. I run this script via custom Automator Application:

  1. Search for (Spotlight search) and run Automator
  2. Click "New Document" at bottom
  3. Choose "Application" for new file type
  4. Click on "Utilities" from list
  5. Double-Click "Run AppleScript"
  6. Replace (* Your script goes here *) with:

    do shell script "kextunload -b com.apple.iokit.BroadcomBluetoothHostControllerUSBTransport; 
    kextload -b com.apple.iokit.BroadcomBluetoothHostControllerUSBTransport" with administrator privileges
    
  7. Press play to test (will prompt for password)
  8. File->Save to desktop or wherever

Run the automator app whenever bluetooth devices won't connect

4
  • Worked for me, thanks! Very unfortunate Apple hasn't fixed this issue. The work around is simple, but terrible user experience. Very annoying bug though so I'm very happy you posted this.
    – Tom
    Dec 18 '14 at 2:54
  • Well, only worked a few times. Doesn't seem to work anymore (or reliably). Not sure how Apple can screw up so bad. =( They truly are the new Microsoft.
    – Tom
    Dec 27 '14 at 16:10
  • I'm using 10.10.5 and i'm getting this error kextunload: option requires an argument -- b /bin/sh: line 1: com.apple.iokit.BroadcomBluetoothHostControllerUSBTransport: command not found kextload: option requires an argument -- b Use kextutil(8) for development loading of kexts. usage: kextload [options] [--] [kext] ... use kextload -help for an explanation of each option /bin/sh: line 2: com.apple.iokit.BroadcomBluetoothHostControllerUSBTransport: command not found
    – adantj
    Sep 16 '15 at 16:26
  • 1
    @adantj Point 6 has been updated, please try with that.
    – webaholik
    Sep 16 '15 at 22:53

Not the answer you're looking for? Browse other questions tagged .