I previously used Image Capture (ie. this solution: How to mass delete your photos in your iPhone?). It seems like the delete functionality was removed in Yosemite. Now what? I have 800+ photos and I don't want to select them one by one.

When I connect to iTunes, it says "iCloud Photos is On" - and does not allow me to sync through iTunes.

enter image description here

  • 1
    Not seeing any problems using Image Capture in Yosemite to delete photos from iPhone. See screenshot: i.imgur.com/lfkfllT.png – tubedogg Nov 12 '14 at 5:55
  • possible duplicate of How to mass delete your photos in your iPhone? – tubedogg Nov 12 '14 at 5:55
  • 1
    @tubedogg See my edit. There is NO delete option. – Bowen Nov 12 '14 at 16:38
  • 1
    Is your iPhone connected in iTunes when you open Image Capture? If so, eject your phone in iTunes, disconnect the cord, quit iTunes, then reconnect your phone and see if the Delete option reappears. – tubedogg Nov 12 '14 at 17:40
  • 1
    For me it finally started to work after turning off "iCloud Photo Library" on the phone. I already had it turned it off in OSX and I closed Photos and iTunes. I did not have to restart my phone. I did unplug it and plug it in again and did restart Image Capture. – root May 3 '15 at 18:52

Turning off iCloud Photos Beta and restarting my iPhone worked, then the option returned in Image Capture. Seems to be a bug in iCloud Photos Beta

  • This didn't work for me. It still shows the iCloud icon next to the iPhone in Image Capture and there is still no delete option. Even after disabling iCloud photos on my phone and mac and restarting both. On El Capitan. – Justin Oct 22 '15 at 18:08

I'm using OS/X Yosemite Public Beta. The delete functionality does work out of Image Capture, but the control is not in the menu toolbar. The delete icon on the bottom of the window works (red circle with slash).

  • Thanks! The red circle worked for me, even though Edit>Delete is greyed out. – Nick Edwards May 24 '16 at 8:52

When your iOS device is using the iCloud photo storage option, you can delete all the photos using the web interface at https://icloud.com as opposed to using Image Capture.

You can "delete" all the local copies of the photos by navigating to:

  • Settings > iCloud > Photos

Tap the iCloud Photo Library button and then tap "Remove from iPhone" which will delete all photos off the iOS device in question (if it's not an iPhone - the prompt should say iPad or iPod).

This failed me on my iPhone 11 Pro and iPad Pro with iOS 13 so they have residue photos left. In one case 36,000 photos that take up 45 GB of space. I will have to look at a second step since this does not seem to be as reliable at cleaning with recent hardware and software. Image Capture of course works, but I’ll see if I’m clever enough to do it untethered to a computer.


This doesn't really solve the bug that you seem to be encountering but if you just pull up iPhoto and import the photos it will ask you if you want to keep the photos on your device or delete them. Kind of quick and dirty but if you want them gone that will work.


This worked for me -- Turn off/uncheck "Photos" in iCloud on your Mac & iDevice. Restart both devices. The delete button was then displayed in Image Capture. Prior to restarting my iPhone, Image Capture displayed my photos in duplicate. The restart solved this.

Hope this helps!


This seem to be a bug on iCloud Photo Library (maybe Apple will officially disable this for everybody once the OS X Photos app is released).

As a workaround, you can login on iCloud Photos online and delete the pictures from there. Use the Select Photos button on the top right corner (next to Upload). It's not optimal, but much faster than doing it on the phone.


There's a little box in the lower-left corner of the Image Capture window. Click the box and the "Delete after import" option should appear (at least it did for me).

  • There is no such option in Yosemite. – Samuel Lindblom Jul 20 '15 at 14:44

I have the same issue, I think it's a bug in iCloud.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .