1

I ran into a bug (or feature) in OS X 10.9 that I can't figure out.

If I'm trying to log into two servers, and I use "guest" credentials to log into one of them, things get screwy.

Example:

  1. Connect to Server1 (smb://server1) as a "Guest." Select share. Works great.
  2. Connect to Server2 (smb://server2). Finder does not give me the option to log in. Instead, it shows a box with a list of shares on the server. When I try to connect to a share, I get an error saying I do not have the right permissions.

The reason? I'm apparently also logged in as GUEST to server2. Check it out:

screenshot

In most cases, I can't disconnect from the server, regardless of how many times I click the button. I have to restart the system instead.

This is not a problem in OS X 10.6.8, nor in 10.10. I've also tried connecting via SMB1 (using CIFS, and by forcing SMB1 at the account level). I'm at a loss as how to fix this from the client end. Any thoughts?

  • Have you tried connecting to the share using command-K and then using smb://DOMAIN;User@ServerName/ShareName ? – bmike Nov 11 '14 at 21:47
  • Thanks for your comment, bmike. Yes, I still get the permissions error. Also, I've tried using CIFS instead of SMB, and forcing SMB1 instead of SMB2. – ericbakes Nov 11 '14 at 21:52
  • @ericbakes are server1 & server2 member of an AD? – klanomath Nov 17 '14 at 22:11
  • @klanomath, server02 is a member of an AD. server01 is not. – ericbakes Nov 24 '14 at 16:29
0

Update: I had to disable the Guest account on SERVER2. The guest account didn't have access to any shares, but it seems that simply having it active was enough to cause a problem. Here's what I think happened: 1) Log into server1 as "GUEST". 2) Log into server2. OS X must cache network credentials, so tried "GUEST." 3) Server responded with a list of shares, but since GUEST didn't have access, returned permissions error when I tried to open a share. Still seems buggy to me. If anyone has additional insight, feel free to post here.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .