1

I'm restoring iPad from iCloud (context) after factory reset, but the app I need to restore from iCloud doesn't show up as scheduled for install: App Store > Purchases shows an icon to download the app from the cloud (which will not restore its data, as I've seen before the reset).

How can I restore the app I need and its data from the iCloud?

I know the app is there backed up as it's shown in the list of iCloud-backuped apps (iCloud > Storage & Backup > Manage Storage > (my device) > Backup options) now after reset-and-restore--and also was there before I initiated factory reset.

1

My specific situation was that initially I tried a backup version that was too late to contain the app required. Once I switched to an earlier backup, the app was there and successfully restored with all its data.

0

Ok this was my scenario - I updated to a new phone restored from the cloud. An app (Notespark) that i needed which was no longer supported or sold in the store didn't show up. (Note to self: ALWAYS BACKUP TO ITUNES BEFORE BUYING A NEW PHONE. THERE WILL ALWAYS BE SOMETHING ICLOUD MISSES.)

After research and several attempts to re-restore and making a couple more backups along the way, I realized that the data was actually brought over, but there was no app. How did I find this out?

When I manually added the app, the current info didn't show. So I restored an older version and the newer info then showed in the app! (Lucky me.) I made sure to create a backup from this so at least I had a snapshot of when the app data was current.

Now my dilemma was using a phone that was sleep since July but have current data in that app or vice versa. So to finally merge the two I went and tried iExplorer.

I then restored the more recent backup I did and then using the program, moved over the last backup's app data (the one I needed) using iExplorer, rebooted, and bam- everything is finally merged.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .