6

When I maximize some Flash (version 15.0.0.xxx) videos to fullscreen, only the top left quarter of the screen is showing video, the rest is completely black.

I've tried this on OSX 10.9 and 10.10, 2014 Macbook Pro, 3 browsers (Safari, Chrome, and Firefox) with no plugins, no additional screen, and hardware acceleration set to enabled and disabled.

Here's a workaround I've found: right click on the 1/4-screen video and look for the Stretching is <type> item in the options list. Click on that and the video will fill the screen. Keep repeating to get back to the 'Stretching is none' setting.

What can I do to debug this?

  • I am having the same exact problem, and I don't even have that Stretching item in options list. Gonna put a bounty on this, as this is something that annoys me as hell. – Ivo Pereira Dec 29 '14 at 21:06
1

I've found it. After looking a little further, I was able to find something I missed some time ago.

  1. In the URL bar enter chrome://plugins/
  2. Locate the Flash plug-in, you should see multiple versions listed
  3. Click Disable for the plug-in with the location /opt/google/chrome/PepperFlash/libpepflashplayer.so
  4. You should still have one enabled in another location, like /usr/lib/adobe-flashplugin/libflashplayer.so
  5. Restart Chrome (quit and open again)

Source: https://code.google.com/p/chromium/issues/detail?id=135353#c25

This fixed it for me!

  • Since Chrome 57, the chorme://plugins page has been removed. – tyteen4a03 Feb 19 '17 at 23:14

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .