2

As far as I can tell, I have all iCloud settings turned off, but I am still incessantly asked to log into iCloud. Is it possible to not use iCloud without being reminded every 5 minutes to log into iCloud? I'm on a MacBook Pro running OS X 10.9.5. Any insight is much appreciated!

2

In your system settings go to iCloud and make sure you have all of the switches set to off. If you have any other devices (iPad, iPhone) do the same. Open Mail, iTunes, Messages, etc.. all the default apps, and make sure your settings are disabled in each.

In this article, it's mentioned, that this may be a bug with OSX and by clearing all your cache and then turning the switches all on, saving, and off again may resolve the issue.

Running this command in terminal will disable applications from like Textedit from trying to save to iCloud by default:

defaults write NSGlobalDomain NSDocumentSaveNewDocumentsToCloud -bool FALSE

and this command should disable the iCloud prompt when you login

sudo defaults write "/System/Library/User Template/Non_localized/Library/Preferences/com.apple.SetupAssistant" DidSeeCloudSetup -bool TRUE

(Note the quotes are required since one of the pathname components, "User Template", has an embedded space.)

  • 2
    Note that running sudo commands without knowing exactly what they do is potentially very dangerous to your system's well-being. This particular one modifies the User Template default preferences to bypass the iCloud setup tool. – tubedogg Nov 11 '14 at 7:25
  • Thank you. I currently have all icloud settings turned off on both macbook pro and iphone6. These are the only two apple devices in the mix. When running the sudo command, I am told the -bool is an unexpected argument and defaults have been left unchanged. – Christian Russell Nov 11 '14 at 16:12

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .