5

I've recently upgraded iMacs the other day. Can't figure out how to toggle the following overlay to show up when switching inputs using keyboard hotkeys

Screenshot

Right now the shortcut will toggle the input switch, but doesn't display the overlay below.

EDIT If it helps any I am using the first gen 27" Retina 5k iMac with Yosemite 10.10.1.

5
  • Never seen that before, sure it's not a 3rd party addition?
    – Tetsujin
    Nov 9, 2014 at 20:08
  • I've disabled every known third-party addition. Fairly sure it is a system setting. I am thinking this is an Accessibility setting.
    – Viet
    Nov 10, 2014 at 5:24
  • I found a guide that illustrates the overlay macosxtips.co.uk/index_files/… It is activated by having the modifier key held down when initiating the input source switch. For some reason is isn't working for me on my iMac + Yosemite, but works with my 13" MBPr + Yosemite.
    – Viet
    Nov 10, 2014 at 18:35
  • What shortcuts are you talking about?
    – Brethil
    Dec 15, 2014 at 12:48
  • The shortcut mentioned in the guide I linked, CMD+Space. I've changed the hotkey to ALT+SPACE to avoid conflicts with Spotlight. So the modifier key in this case is either CMD or ALT.
    – Viet
    Dec 15, 2014 at 18:42

2 Answers 2

9
+50

In the Keyboard system preferences panel, select the Shortcuts tab then the Input Sources entry on the left. Enable the "Select the previous input source" checkbox and assign it to the keyboard shortcut you wish.

The input source switcher window ONLY works with this shortcut. It will not show if you use the "Select next source in Input menu" shortcut.

I'm guessing that the 2nd shortcut was added later by another developer. Besides the lack of this secret switcher feature, notice the wording of the shortcut description. If the same person did both, they probably would have called it "Select the next input source".

3
  • THANK YOU. This is the solution. Odd oversight by Apple on this one.
    – Viet
    Dec 18, 2014 at 1:07
  • Happy to help. Could you do me a favor and post a link to download that awesome desktop background picture? Dec 18, 2014 at 4:37
  • Here you go! i.imgur.com/DTbfnfq.jpg
    – Viet
    Dec 18, 2014 at 6:13
2

I don't know what your set shortcut is, let's say it's control + space. Simply hold down control, press space but don't release control. The overlay will be shown.

Also, there's no need for three input sources. I have two input sources and it works.

4
  • Yeah... Holding the modifier key isn't displaying the overlay. This is with a clean Yosemite install. I've also disabled all third-party apps to ensure there isn't any conflict.
    – Viet
    Dec 15, 2014 at 18:44
  • @Viet, you do press and hold both keys for at least a second or two right? This overlay will only show up if you press and hold them for a moment.
    – iskra
    Dec 15, 2014 at 19:24
  • @iksra Yes, I did hold these the keys down. I am able to display the overlay on the other Mac products I have access to: MBPr (the screenshot from the OP is from my MPBr) and five older iMacs. I'm incline to believe this is a setting issue or a specific issue with the iMac 5k Retina. I've tried reformatting the Retina 5k iMac, which hasn't yield any results.
    – Viet
    Dec 15, 2014 at 19:45
  • Then I suggest you file a bug report here bugreport.apple.com
    – iskra
    Dec 16, 2014 at 1:41

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .