1

I'm running OSX 10.9.4, and my default shell is set to z shell.

I was just working out my installation of Ruby and RVM and playing around with irb when I suddenly notice that my window title says "bash" instead of my default zsh heading.

Running echo $SHELL returned /bin/bash, and I confirmed that I was running bash.

The (temporary) fix was simple - run chsh -s /bin/zsh, but this instance repeated the switch to bash every time I executed irb.

I was not able to replicate the situation, but I was wondering if anyone had insight into this issue so that I don't run into this error again.

  • Unfortunately, none of those are my issue. There was a glitch that switched my shell to bash when I ran irb, and I have not found any results explaining the cause. – user3172050 Nov 9 '14 at 18:19
  • Have you tried to file a bug against irb? it might well be possible that irb is the sole cause of this problem you are having – user1256923 Nov 10 '14 at 22:11

You must log in to answer this question.

Browse other questions tagged .