5

I had pinch to zoom working fine after installing Yosemite but after a month or so it's stopped working. The setting is enabled in Trackpad > Scroll & Zoom and it seems none of those gestures are working anymore. I can use 4/5 fingers outwards for Expose though.

How can I get the full functionality back?

1
  • You might try doing an SMC Reset or zapping the PRAMs of your Mac before reinstalling. Those solve a surprisingly large chunk of the Mac problems I see. Nov 9, 2014 at 5:54

5 Answers 5

-2

Not for any of my 6 macs. Try reinstalling it on a fresh HFS+ formatted HD.

3
  • 1
    Your suggestion for a feature that worked for a month then stopped is to do a complete clean install of the OS? o.O
    – tubedogg
    Nov 9, 2014 at 7:57
  • Yeah it's a bit weird. It seems to have started working again on its own, so doing nothing is another alternative. It's possible it only affects a small number of environments. Nov 10, 2014 at 6:14
  • Upvoting, this is actually a good answer, better answer would be to fix error on the disk (using recovery options). It is a fact that macOS is randomly breaking feature notably when kernel panic and crashes happen, some segments of the disk get corrupts and some of them creates software issues. May 31, 2019 at 9:15
21

Turn off pinch to zoom in preferences, then turn on again. This has worked for me before. If that doesn't work then doing a reboot will usually fix any and all trackpad issues. Problems after a reboot? Check out the above slightely more extreme ways around the problem..

1

I tried to toggle Pinch to Zoom off and on in System preferences but it didn't fix the issue. So I put the MacBook to sleep, woke it up and then Pinch to Zoom started working again.

0

If you have Ad Block installed..

Turn off Ad Block in Safari's Extensions..

Uncheck and then recheck Pinch to Zoom in Trackpad settings..

Test.. If working now turn Ad Block back on.. and test again

It should now work as normal.

-2

I reconnected my trackpad and it's worked

2
  • How can you reconnect something that is built-in? Jan 18, 2018 at 1:18
  • Worked for me. I use a Magic Trackpad 2. Apr 27, 2022 at 10:35

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .