1

I'm using Microsoft Remote Desktop on OS X Yosemite to control a Windows desktop and a few virtual machines.

Whenever the display on my Retina MacBook Pro turns off, it closes all remote desktop sessions.

Is this because it is also disconnecting the network connections when the screen turns off? Is there a setting I can adjust to prevent this from happening?

Thanks for any help!

EDIT: I think this was actually an issue with a wifi connection issue that many people are having with Yosemite. RDP connections were being dropped when wifi went down, I just didn't notice the wifi dropping when I wasn't actively using the computer. Many people with the same issue here: https://discussions.apple.com/thread/6601963

1

Does it do it when the screen sleeps, or when the computer sleeps?

If only when the computer does, then set System Prefs > Energy Saver - Computer Sleep to never & Display Sleep to whatever you like.

enter image description here

You can then test using System Prefs > Desktop & Screensaver > Hot Corners & assign one corner to put the display to sleep.

enter image description here

  • 1
    I think this was actually related to a wifi connection dropping issue in Yosemite. I've posted a related link in the OP. Thanks for your help, though. I took your advice with the hot corners and confirmed that the display going to sleep did not disconnect the RDP session. – Jesse Schoff Nov 10 '14 at 5:29
0
Preferences -> Energy Saver -> Power Adapter -> Prevent computer from sleeping automatically when the display is off

(tested on MacOS X Yosemite, possibly available only on laptops)

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .