I have a Macbook White from 2010. I have been using it for a while and everything works except the internal keyboard which is broken because of a tea spill. An external PC-keyboard (USB) is attached though but it doesn't work properly.

I had installed Yosemite and it worked fine, but later I decided to reinstall Mountain Lion again.

I tried to enter the boot menu with the alt-button to reboot to my second partition but it didn't work.

So I've changed the Start Volume in the System Preferences in Yosemite which was successful but now I'm stuck in the 'Mountain Lion Install'-partition which just loads to a grey screen and nothing else happens.

Is there any solution guys?

  • How did you "create" your 'Mountain Lion Install DVD'? – klanomath Nov 8 '14 at 16:18
  • I have a partition that i install my montain lion from. It worked before but this time it just loading and i can't use another partition cuse I'm stuck in there :( @klanomath – G unitzo Nov 8 '14 at 16:31
  • Just turn off your Mac and restart to Yosemite with the boot menu. You have to press the Power Button of your Mac at least 10 seconds to do so. Finishing this task successfully we will continue examining your partitions. Please put the '@user' at the beginning of your replies, otherwise i won't be notified. – klanomath Nov 8 '14 at 16:43
  • @klanomath sorry but i can't load the boot menu. When i hold ALT or anything else. I tried to hold the power button but i did´nt help. – G unitzo Nov 8 '14 at 16:51
  • You can't turn off your MacBook with the Power Button? Do you have a second (USB-)keyboard? – klanomath Nov 8 '14 at 16:54

I also use a non-mac keyboard and have seen the issue where it skips the boot menu. The native keyboard works both from a cold boot and a soft reboot. The 3rd party keyboard only works from a cold boot and not from a reboot. You should be able to power down your Mac and power it back on and have the boot menu work with any keyboard.

I've also read a few places that it matters which USB port you use for the third party keyboard (for the boot menu specifically). You could try moving the keyboard around to see if you get the desired behavior. YMMV.

| improve this answer | |

I have fixed the problem. I fixed it by mounting the hard drive on another MacBook and there i deleted the partition for "Montain Lion-Install"-partition. When i mounted the hard drive back to my MacBook it booted to the secound partition (Yosemite). But i have another problem, how do i make the boot loader work now from the OS X Yosemite?

| improve this answer | |

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .