1

I just replaced the stock OEM hard drive on my 2010 macbook pro 15 inch with a Samsung 840 Pro SSD 256GB and installed Yosemite on it from scratch with USB (the first time i am using Yosemite). Now when i boot my macbook pro up it takes about 5 seconds to get from powered off to the log on screen, but then when i enter my password it shows a loading bar that slowly fills and my user icon changes to an apple logo. Then after about 20 seconds it logs in. Moreoever the log on screen is gray with the user icons, which is not my background on my account. But if i log in and then log out it changes the log in screen to be my desktop background.

This is a big change from my old mavericks where it took longer to boot up but instantly logged me in. I thought SSDs had super quick boot and log in times.

Here is a video of what is occurring to me.

It shows the quick boot to log on screen with the strange gray background, me logging in and having my icon change to an apple with a loading bar under it, and then me going to a website, and logging out, notice that after i log out the log on screen changes to my desktop background. And then i log in again and it goes quickly unlike the first time.

Link to console messages from boot

After doing a restore via the net with cmd Option R it seems to be booting normally

Here is a link to the console messages now after i restored it.

  • could you show us the Console log from boot and the following 30-50 lines – Ruskes Nov 8 '14 at 6:00
  • how do i access that?, but i have updated the original post with a video of the problem – user2237160 Nov 8 '14 at 6:04
  • I saw the video, but now need Console log to find out what is making it slow. In your utility folder open console and find the time stamp from when you started the boot then copy some 50 lines after that and paste in here. – Ruskes Nov 8 '14 at 6:07
  • i have updated the original post with the entirety of the console after a fresh reboot. – user2237160 Nov 8 '14 at 6:19
  • Thank you for the console log, let see what is going on in there :) – Ruskes Nov 8 '14 at 8:04
2

This is normal behaviour for Yosemite for users with FileVault enabled (i.e. Your Mac's primary disk is encrypted).

The authentication process is done earlier because without authorisation from the user the OS cannot access the rest of the disk.

This is a good thing, and I think you are (mostly) mistaken that it takes longer to boot up — since now you are watching the screen and waiting after entering your login/password the result is that one fixates on the screen and the time it takes to present the OS X graphical user environment, and comparing it with your prior experience of how much time it took to go from authentication to the GU environment. But the total time from power up shouldn't be noticeably longer.

To disable this behaviour:

Open System Preferences > Security & Privacy > FileVault

From there you can click on the 'Turn off FileVault', after which you will be asked to restart and you will have the normal boot up behaviour and the OS will start to decrypt your disk in the background.

screenshot of system prefs > security & privacy > filevault

EDIT: The 'extra long' boot time with FileVault occurs once only, at the first startup/restart after enabling FileVault as the OS is finishing the process required. After this, it should be as fast as normal. I double-checked this whole process by disabling FileVault and re-enabling it on one of my machines so I could be sure.

Nb. (if there is any slight increased length of time in booting up, it is more likely as a result of the disk encryption not because of your upgrade to Yosemite per se.)

  • this may explain it as when i restored my mac i chose install a new OS X and this time i chose not to use filevault (the first time i chose to use it by mistake, the second time was able to read what it was and google whether or not people like it). It seems most people dont really like it – user2237160 Nov 8 '14 at 18:30
  • Well, all I can say is that it is definitely the answer and the explanation, I am glad it helped clarify the issue. Would you mind marking the question as answered then, please? – Benjamin R Nov 8 '14 at 20:26

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .