0

I'm using a macbook pro running Yosemite. I was trying to create installation media to install linux on an SD card, and I used a USB key that had a bootable windows installation on it. I thought I had overwritten it, and booted from it, expecting the linux installation to boot up. Instead, the old windows OS started up, and after I shut it back down, it kernel panicked every time it tried to restart. After glancing around, it appears that the windows installation added an MBR boot partition where it shouldn't have been, and overwrote the normal EFI scheme.

I cannot paste output directly, as the only way to boot from the computer in question is to boot with a yosemite install drive, but currently the partition map is one "disk0" with no partitions, of the full size of the hard drive, and then various other disks representing the Yosemite install disk. I've tried to use dd to copy the EFI scheme from the Yosemite Install "disk1s1" to the hard disk "disk0s1" but it returns "Operation not Supported."

Let me know if I can give any more information. Thanks!

  • Normally the EFI is a hidden protected partition, so I am questioning it was overwritten. – Ruskes Nov 7 '14 at 18:02
  • I think it was maybe added somewhere else instead, but in any case it wouldn't boot, and now there's no partition map. I'm wondering if there's a way to manually create the EFI, or reset it to default in some way. – jaxuru Nov 7 '14 at 18:05
  • you could download it from here support.apple.com/en-us/HT1237 – Ruskes Nov 7 '14 at 18:09
2

If your EFI is not working, you will need to restore it.

Download from here for your model.

Then follow the procedure described here.

  • This answer (rather the linked page) is outdated for some macs, eg, macbookpro 11,4 – Rondo Jan 28 '16 at 4:40

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .