3

When booting up and logging into my MacBook Pro, I get the following error message:

localhost com.apple.xpc.launchd[1] <Emergency>: Boot task failed: fsck-safe
localhost com.apple.xpc.launchd[1] <Emergency>: Shutting down in 3 seconds.

This is an image of the error:

enter image description here

I am running OS X Yosemite, on a mid 2011 MacBook Pro.

  • Does it boot in Safe mode (press shift during boot) or in Single user mode (hold V) – Ruskes Nov 7 '14 at 17:30
  • No, holding down Shift or V won't do anything – user906379 Nov 7 '14 at 17:34
  • the fsck failed means your hard drive failed ? – Ruskes Nov 7 '14 at 17:37
2

Hold alt during startup, you will then be able to boot from something called "recovery partition". When that is booted, in the menu select "disk utility" and try to repair disk and/or volume.

  • would that not be the cmd-r ? – Ruskes Nov 7 '14 at 17:33
  • cmd-r will directly boot the recovery partition, while holding alt shows you a list of all bootable partitions available. So both will do ;) – Kevin Grabher Nov 7 '14 at 17:35
  • I did not know that so a + from me :) – Ruskes Nov 7 '14 at 17:51
1

Based on the fsck error that would be your Samsung SSD failing.

Since you can not boot in Safe mode or any other including recovery, your only option is to boot from a external drive.

Then try to repair your hard drive.

1

Tried everything posted here and in other Apple forums but it wouldn't work. In the end, I booted using a USB drive and deleted all existing partitions on the failing SSD. Once all partitions were cleaned, I reinstalled Yosemite and the computer is up and running again.

1

Similar symptoms on my 2011 MBP.

The shutdown would occur during the boot process as the progress bar is loading, about 50-60% of the way the machine would just shutdown, everytime.

I tried resetting the PRAM and SMC controller as per Apple's instructions. This didn't help directly.

I ended up going into internet recovery mode, and attempted to use the Disk Utility to repair/diagnose the main HD. Disk Utility couldn't mount it or perform First Aid.

So I opened up the terminal and ended up doing the following:

  1. Unlocking my encrypted drive.
  2. Mounting the drive with mount_hfs and specifically ignoring journalling. If this step succeeds, I'd spend some time backing up important files to an external drive or USB stick, as this may be your only chance to do so if you've got an incurable issue with your HD.
  3. diskutil disableJournal on the drive after it mounted.
  4. diskutil enableJournal on the drive.
  5. diskutil unmount the drive.
  6. Reboot.

Step 1 is explained here (archive). Step 2-5 are explained in a bit more detail here (archive).

My system then booted up correctly and seems to be working okay. I suppose the issue was a corrupt journal file that the system kept on failing on each time it booted, and by disabling/re-enabling the journal I effective "cleaned" it up. I can also confirm that steps 3 & 4 cleared out some large *journal* files in the root of the problematic drive.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .