0

I imported all the contacts to my iPhone via .vcf file and now they are not sorted by name. They are all under the # sign.

Screenshot

I imported contacts with a program called Wondershare TunesGo. I just clicked import and selected vcf file.

A contact from VCARD.

BEGIN:VCARD
VERSION:2.1
N;CHARSET=UTF-8;ENCODING=QUOTED-PRINTABLE:=C4=8C=75=6B;=4D=65=74=61;;;
FN;CHARSET=UTF-8;ENCODING=QUOTED-PRINTABLE:=4D=65=74=61=20=C4=8C=75=6B
TEL;CELL:0038640823731
END:VCARD
1
  • This is a bit of a wild guess, but the first name on that list has an emoticon in the name. Maybe that triggers a bug. How about trying to reimport your contacts without that name? – root Nov 7 '14 at 17:32
2

It worked awesome!

Having all your contacts under something as arbitrary as # is not a very good solution and I can relate that you would like a little more structure on your device.

Have you tried logging into your device with iCloud, and then going into www.iCloud.com and importing the vCard following this article there? If you have the vCard a safe place and a backup of your contacts, I would recommend you to delete all your contacts first and use this method.

Here are the steps to import a vCard with iCloud:

  1. Data should be on
  2. Go to Settings > iCloud
  3. Turn On Contacts
  4. Login into icloud.com with your username
  5. on iCloud you can see all your applications which you share on iCloud, click on Contacts and see if all the contacts are synced. Here all names will be sorted correctly and no # would be there
  6. on iPhone turn off Contacts in Setting > iCloud and choose Delete from iPhone
  7. come out and turn on Contacts again in Settings > iCloud
  8. give it some time and now go to Contacts: all contacts will be synced from iCloud and the # sign should vanish.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .