0

I was previously running Windows 8 pro in Fusion 6 on Mavericks. I had the VM configured with 2 processor cores and 4GB RAM. The main applications I use in Windows are as follows:

  • Visual Studio 2013
  • SQL Server Express
  • SQL Server Management Studio
  • IIS Express
  • Google Chrome (for testing and debugging with Dev Tools)

This setup worked completely fine, almost as good as a native Windows PC. I have recently upgraded to Yosemite and Fusion 7.0.1 along with upgrading VMWare Tools.

This has caused significant performance problems with my setup. Most notably:

  • The action I perform most is switching between VS2013 and Chrome (alt-tab), this used to be absolutely fine and for all intents and purposes was an instant switch. Now that same process can take anywhere between 1 and 10 seconds.
  • Opening dev tools in Chrome now takes on average about 5 seconds.
  • Making a DOM update in Chrome dev tools now takes a couple of seconds.
  • Attempting to inspect a DOM element (via the magnifying glass icon) now takes a couple of seconds.
  • Even switching between tabs in Chrome now takes anywhere up to 10 seconds which is just ridiculous. I never have more than about 5/6 Chrome tabs open at any time.

All of these used to be practically instant in the old setup.

All of these things combined for me are completely unacceptable. Although they are all only small amounts of time on their own, when they're added up it's leading to huge amounts of frustration and ultimately loads of unnecessary lost time.

I've done the usual of closing down any unnecessary background apps/services, I've increased the processor cores to 4 and increased the RAM to 6GB. Still no noticeable improvement.

To go from a setup which was working incredibly well and then supposedly "upgrading" and ending up with a setup which is significantly worse is very frustrating. I'm hoping that someone somewhere has come across something similar and can suggest something I can do to make my setup get back to somewhere near where it was before.

Many thanks, Lee

1

I also posted this on the VMWare forum: https://communities.vmware.com/message/2446538#2446538

I had an answer back from DrTone who said the following:

Shutdown your VM and change your hardware mode from 11 to 10 and restart your VM. Your performance should be back to what you expect. Fusion has MAJOR issues with hardware level 11.

I did as he suggested and after some basic testing, performance appears to be back to where I was prior to upgrade which is good news.

  • No probs, glad it was useful. Been running Yosemite/VMW7/Win8 on hardware level 10 ever since and it's been totally fine. – lee_mcmullen Feb 7 '15 at 22:01

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .