0

So when I have, say, Safari open, or Firefox, but not Chrome, and go to (in Safari) FILE>SHARE>EMAIL THIS PAGE (or the equivalent in Firefox)...suddenly Chrome opens to the Network Solutions webmail login, which I was working in earlier, until the server locked up. I've dumped caches, cookies, histories, run diagnostics...no luck. Ideas?

1

Chrome is set as the default browser on your machine, and the default email is set as your Network Solutions webmail.

To change the default browser, go to System Preferences > General > Default web browser and change it to your choice of browser. (You can also change this in Safari under the Safari menu > Preferences > General > Default web browser.)

To change the default email program, open Mail, then click on Mail menu > Preferences > General > Default email reader. It is almost certainly set to Google Chrome right now. You can change it here to whatever you like.

If you want to leave it with Chrome, but change the email that opens when you use Email This Page, you can change the default email handler in Chrome. Go to Chrome menu > Preferences > Show advanced settings... > Content Settings button > Scroll to Handlers and click Manage handlers. In the window that appears, across from mailto there should be a drop-down where you can select what email website you would like to use. Note that this menu may only contain Network Solutions, if you have never visited another webmail service in Chrome.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .