10

I've got my headphones connected, and I've checked system preferences to make sure they are the audio output device. Most sound comes out through the headphones, like Spotify and YouTube. But, system sounds come out through my thunderbolt display, like dragging a file to the trash.

Seems to only be a problem since I upgraded to Yosemite.

  • 2
    Did you check what System Prefs > Sound > Sound Effects thinks it should be coming from? – Tetsujin Nov 6 '14 at 18:05
  • Some app will do that if you set them to do so. Example the Audio MIDI app in your utility folder. – Ruskes Nov 6 '14 at 18:12
  • 'Play Alerts & Sound effects' device ought to just mirror the setting in Sound, either one will alter the other. (though I'm still on Mavericks, haven't made the leap yet) – Tetsujin Nov 6 '14 at 19:44
20

Under "Sound Effects" tab, change "Play sound effects through:"

Instead of automatically changing this option, when I plug in headphones this setting remains unchanged.

enter image description here

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .