1

In most text areas, ctrl-a and ctrl-f used to move my cursor to the beginning/end of the line, but now I get "^A" printed to terminal, and nothing happens in other input areas.

Any ideas what happened?

3
  • So, the move is broken in textedit too? CTRL-A beginnig of line, CTRL-E end of line, CTRL-F one char right, CTRL-B one char left.
    – clt60
    Jun 7, 2011 at 17:12
  • 2
    hmm, works in textedit, must be my bash key bindings
    – klochner
    Jun 7, 2011 at 18:49
  • I also have it broken (OS-X Lion Preview4) but I don't have any "set -o vi" settings. Ctrl-A does not have any effect! WTF? I cannot use screen to switch or create new screen sessions.
    – user7351
    Jun 21, 2011 at 1:12

1 Answer 1

2

It was my bash key bindings - I had "set -o vi" in .bashrc.

2
  • 1
    So use, ESC-0 for the beginning of the line, "$" to end, and so on... :) but, you probably know "vi" when activated the vi-mode ;) (i'm using it too) :)
    – clt60
    Jun 7, 2011 at 19:33
  • indeed - just overlooked that I would lose the emacs-style bindings :)
    – klochner
    Jun 7, 2011 at 21:29

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .