Since upgrading to Yosemite (did a wipe of my HD before installing, so no settings was there from Mavericks) I can only connect my Magic Mouse normally once per boot.

Normally you would be able to connect the mouse, sleep the computer, connect the mouse again, however I have to reboot my MacBook Pro after the sleep, if I want the Magic Mouse to work again.

I can see the device in both the Bluetooth preference pane and the Bluetooth menubar icon dropdown, but clicking connect in either of them does nothing. enter image description here enter image description here

Sometimes deleting the pairing and re-pairing with the mouse works, however most of the time it doesn't.

I have tried to reset my nvram and deleting /Library/Preferences/com.apple.Bluetooth.plist, without any success.

When using Mavericks and below, I have never had any issue with my Magic Mouse and the problem still exist when using a different Magic Mouse on Yosemite.

Any suggestion on how to fix this, without downgrading to Mavericks?

  • Have you tried performing an SMC reset yet? – ProfFrnswrth Nov 5 '14 at 14:57
  • I would try reinstalling the OS then through the Recovery Partition. This will not delete you personal information but just reinstall the core system files. – ProfFrnswrth Nov 5 '14 at 18:37
  • @ProfFrnswrth reinstalling OS X didn't solve the problem. – Tyilo Nov 18 '14 at 18:19
  • A similar question with some console logs is apple.stackexchange.com/questions/156863 – bmike Nov 25 '14 at 19:47
  • 1
    Try to hold mouse button for 2 secs after your Mac woke up. My MagicMouse connects after this. May be side effect of intentional design to save battery while idle or something. – Yaroslav Admin Feb 12 '15 at 15:03

10 Answers 10

up vote 129 down vote accepted

I found a solution from this comment on reddit:

  1. Turn off wifi
  2. Reconnect Magic Mouse
  3. Turn on wifi again

I just noticed that the above doesn't work sometimes and instead you have to reconnect the mouse after turning on wifi again:

  1. Turn off wifi
  2. Turn on wifi again
  3. Reconnect Magic Mouse
  • 47
    Seriously Apple?? – n1000 Feb 20 '15 at 7:21
  • 2
    Fixed the issue for me too, with Yosemite, on a Mid-2012 Macbook. I'd like to join the "Seriously Apple??" choir. – sdanzig Feb 26 '15 at 14:58
  • 3
    Can confirm that temporarily disabling Wifi achieves the pairing for me. Looks like a bug in the networking middleware... I expect better from Apple. – Chris Hatton Mar 6 '15 at 8:03
  • 6
    Holy cow, this worked. I've been searching for this for months. Thanks! – Dries Vints Apr 24 '15 at 19:23
  • 2
    Experienced this issue for the first time this morning. I tried the usual things and only cycling the WiFi fixed it. I'm running El Cap for what it's worth. – Thomas Paine Oct 29 '15 at 16:00

I've had issues reconnecting my bluetooth keyboard & trackpad since upgrading to Yosimite. I run this script via custom Automator Application:

  1. Search for (Spotlight search) and run Automator
  2. Choose "Application" for new file type
  3. Click on "Utilities" from list
  4. Double-Click "Run AppleScript"
  5. Replace (* Your script goes here *) with:

    do shell script "kextunload -b com.apple.iokit.BroadcomBluetoothHostControllerUSBTransport; 
    kextload -b com.apple.iokit.BroadcomBluetoothHostControllerUSBTransport" with administrator privileges
    
  6. Press play to test (will prompt for password)
  7. File->Save to desktop or wherever

Run the automator app whenever bluetooth devices won't connect

  • 1
    This works. I have made a script to install sleepwatcher and run those to commands every time the computer wakes from sleep, which has completely eliminated the problem from me: gist.github.com/Tyilo/c92684d277acb62272b5 – Tyilo Dec 13 '14 at 1:45
  • @Tyilo That's an excellent suggestion! The only time I have problems with bluetooth is precisely after waking the macbook from sleep. Thanks! – Jagtesh Chadha Feb 19 '15 at 15:09
  • I was getting syntax, and totally unfamiliar with apple script to me a minute to realize that the line breaks above are invalid, and the com.apple.... must follow right after -b for both. Otherwise you get missing argument errors. (also it did not solve the problem :( ) And this horrible hack is still the only way i suceed apple.stackexchange.com/questions/157357/… – Eddie Mar 24 '15 at 17:13
  • @Eddie, sorry about that, you are correct, formatting got messed up, causing syntax error, I've updated that, however, yes, this only works for some cases – webaholik Mar 25 '15 at 2:07
  • Finally! This should be the selected answer. – reinaldoluckman Aug 28 '15 at 13:54

For many it is because of a WiFi/Bluetooth conflict.

  1. Go to the  Apple menu and choose System Preferences
  2. Go to the Network control panel
  3. Select “Bluetooth PAN” from the list of network interfaces on the left side menu
  4. Hit the Delete key or the [-] minus button to remove the Bluetooth PAN interface

Note: Bluetooth PAN is for connecting to your iPhone for things like "Instant Hotspot" and can easily be re-added using the [+] on the same screen if you need it later.

  • 1
    This worked! +1 for disabling features I don't use anyway. – shadowtalker Nov 11 '15 at 15:33
  • 1
    The mouse stubbornly refused to connect, even with fresh batteries, until I deleted the Bluetooth PAN. Then it connected immediately after I turned Bluetooth off and on. We'll see how it does. – Bob Wakefield Mar 30 '16 at 23:01

This will sound insane, and I admit that, but it worked for me for some reason.

If I used the USB extension cord with my usb keyboard, the pair option magically reappeared in bluetooth. I can only assume it has to do with grounding, but it is worth 2 secs to try and find out if it might work for you.

usb extension cord

  • I can confirm this also worked for me. Nevertheless this is insane and I will send the mouse back. – michid Feb 21 '17 at 7:48

I had the same problem and I think I spotted a possible cause of the problem. My mouse was called "My Name's mouse" with the apostrophe, maybe that was causing the errors.

I have changed the name to avoid using spaces and special characters, now is called just "mymouse" and I don't seem to have the problem anymore.

  • I think your solution works. I'll test a few days to see if it works. – Tyilo Nov 29 '14 at 7:36
  • It doesn't seem to work anyway, sorry. – Tyilo Dec 10 '14 at 14:50

@Tyilo suggestion works. Get this script: https://gist.github.com/Tyilo/c92684d277acb62272b5

Just remember to first chmod your .sh file to be executable. For example:

$ cd your_scripts_dir
$ chmod u+x yosemite-bluetooth-fix.sh

then you may run it as:

$ ./yosemite-bluetooth-fix.sh

Then simply close your lid or make the Mac go to sleep, upon wake up, the Bluetooth icon will appear weird, and will be set as "not available", but a few seconds later your Magic Mouse will be back.

  • Although this works sometimes, it only has a success rate of about 80%, whereas turning wifi off and on seems to work every time. – Tyilo Mar 21 '15 at 15:23

I couldn't get my magic mouse to reconnect after I changed the batteries. All I had to do was turn off wifi and it immediately recognized the bluetooth mouse. No idea why this works, but it did.
I am using a 15"retina MB pro with Yosemite.

Turning off and then back on Bluetooth worked for me.

Settings -> Bluetooth -> Turn Off/On

When attempting to connect a Magic Mouse 2 (The version with the Lightning connector) I had the Lightning-to-USB cable connected to a Thunderbolt display. The mouse would not show up in the Bluetooth pane or the Mouse pane of System Preferences. On a whim, I tried plugging the USB end directly to the MacBook. It paired the mouse immediately. Trying to connect through the Thunderbolt display seemed to prevent the initial pairing. Other hubs might prevent the same thing.

tl/dr: Plug the mouse DIRECTLY into the laptop.

Turning off wifi fixed the problem.

  1. Turn off the wifi.
  2. Mouse will be discovered automatically.

protected by Community Jun 12 '15 at 11:28

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.