1

I've set up a iMac12,1 with Yosemite (fresh) on a second partition. Then I've formatted my first partition (after i migrated my data from my old installation to my Yosemite installation on the 2nd partition)

After formatting, I am presented by a Folder icon in Disk Utility: Disk Utility showing folder enter image description here

But to actually access the folder i had to chown it to my user. What is happening here? The mac also randomly choses to fail at the boot screen, but after some fsck -fy in SU mode it boots again like nothing happened.

UPDATE: Tried formatting the partition again, now i get an error saying that the media cannot be deactivated. I guess OSX just recognizes that this is indeed a folder and unmounting a folder leads to this error. Another thing what striked me: there are apparently 132.629 Folders in this partition (disk utility says that)

diskutil list:

/dev/disk0
   #:                       TYPE NAME                    SIZE       IDENTIFIER
   0:      GUID_partition_scheme                        *1.0 TB     disk0
   1:                        EFI EFI                     209.7 MB   disk0s1
   2:                  Apple_HFS HDD                     499.7 GB   disk0s2
   3:                  Apple_HFS Yosemite                499.0 GB   disk0s3
   4:                 Apple_Boot Recovery HD             650.0 MB   disk0s4
/dev/disk1
   #:                       TYPE NAME                    SIZE       IDENTIFIER
   0:      GUID_partition_scheme                        *1.1 TB     disk1
   1:                        EFI EFI                     209.7 MB   disk1s1
   2:                  Apple_HFS Disk Image              1.1 TB     disk1s2

diskutil cs list:

No CoreStorage logical volume groups found

/etc/auto_master:

cat /etc/auto_master
#
# Automounter master map
#
+auto_master        # Use directory service
/net            -hosts      -nobrowse,hidefromfinder,nosuid
/home           auto_home   -nobrowse,hidefromfinder
/Network/Servers    -fstab
/-          -static

diskutil info /Volumes/HDD

diskutil info /Volumes/HDD
Could not find disk: /Volumes/HDD

diskutil info disk0s2

diskutil info disk0s2
   Device Identifier:        disk0s2
   Device Node:              /dev/disk0s2
   Part of Whole:            disk0
   Device / Media Name:      Customer

   Volume Name:              HDD

   Mounted:                  Yes
   Mount Point:              /Volumes/HDD

   File System Personality:  Journaled HFS+
   Type (Bundle):            hfs
   Name (User Visible):      Mac OS Extended (Journaled)
   Journal:                  Journal size 90112 KB at offset 0x1980f000
   Owners:                   Enabled

   Partition Type:           Apple_HFS
   OS Can Be Installed:      Yes
   Media Type:               Generic
   Protocol:                 SATA
   SMART Status:             Verified
   Volume UUID:              3B40521B-D7F0-3924-9F4E-D9A9FC2FEC16
   Disk / Partition UUID:    00004DD6-4AB2-0000-A05F-0000E4410000

   Total Size:               499.7 GB (499672563712 Bytes) (exactly 975922976 512-Byte-Units)
   Volume Free Space:        863.4 GB (863430361088 Bytes) (exactly 1686387424 512-Byte-Units)
   Device Block Size:        512 Bytes
   Allocation Block Size:    4096 Bytes

   Read-Only Media:          No
   Read-Only Volume:         No
   Ejectable:                No

   Whole:                    No
   Internal:                 Yes
   Solid State:              No

UPDATE: I had a Applescript mounting a sparsebundle Image from a Samba Server for Time Machine Backups (see @klanomath's answer) This script uses perl to execute a system command - hdiutil attach I don't know why, but the existing Mountpoints somehow get messed up when using this script. After updating it with @klanomath's suggestion, Time Machine still runs fine and the mounts in /Volumes seem correct, but the script seems to mirror all of my Volumes in /Volumes/HDDBackup. Look at them:

ls -la /Volumes/HDDBackup/

total 2680
drwxrwxrwt+ 15 root        admin                           578 Nov  5 17:02 .
drwxrwxrwt@  6 root        admin                           204 Nov  6 08:31 ..
-rw-r--r--@  1 mgottstein  Domänen-Benutzer    10244 Nov  4 08:25 .DS_Store
drwx------   5 root        Domänen-Benutzer      170 Oct 30 13:05 .Spotlight-V100
d-wx-wx-wt   3 mgottstein  Domänen-Benutzer      102 Nov  3 16:17 .Trashes
-rw-r--r--   1 root        wheel                       1228840 Sep 20 04:41 .VolumeIcon.icns
-rw-r--r--   1 root        Domänen-Benutzer      629 Oct 30 18:20 .disk_label
-rw-r--r--   1 root        Domänen-Benutzer     2525 Oct 30 18:20 .disk_label_2x
drwx------  29 mgottstein  Domänen-Benutzer      986 Oct 30 16:03 .fseventsd
drwxr-xr-x+  6 root        Domänen-Benutzer      204 Nov  5 09:49 Backups.backupdb
drwxrwxrwx   3 mgottstein  Domänen-Benutzer      102 Nov  3 16:18 HDD
d--x--x--x+  4 root        admin                           136 Nov  5 17:05 HDD1
-rwxr-xr-x@  1 root        wheel                        115716 Sep 20 09:26 tmbootpicker.efi

The System now runs without a hiccup for now, only Disk Utility seems confused - it takes a minute to load the Volumes. I can live with that :) thanks @klanomath!

Thanks!

  • 1
    is there a special reason why you didn't enable journaling for 'HDD'? Please add the content of /etc/auto_master to your question. – klanomath Nov 5 '14 at 13:35
  • I'm pretty sure I formatted it with OSX extended with journaling, OSX just didn't get it it seems... just tried to format again to make sure, but it says that it couldn't deactivate the medium (which is normal i guess, you can't unmount a folder)... – Gotschi Nov 5 '14 at 13:38
  • 1
    please also add the output of 'diskutil list' and 'diskutil cs list' – klanomath Nov 5 '14 at 13:40
  • 1
    i think your mounted disk image interferes with your disk0s2 . looks like both are mounted to /Volumes/HDD (capacity: 500 GB <=> free & used space 1,1 TB) – klanomath Nov 5 '14 at 14:56
  • 1
2

The phenomenon derives from a faulty Apple Script mounting a Time Machine sparsebundle image from a smb-share serving as a Time Machine backup volume to /Volumes. The mounted image interferes with (maybe any) other mounted volume(s) there

The faulty Apple Script:

try 
mount volume "smb://someserver/DATA" 
end try 
do shell script "/usr/bin/perl -Ue '$< = $>; system(@ARGV)' hdiutil attach -nobrowse -mountpoint /Volumes/ /Volumes/DATA/{...}/Timemachine/MGTimeMachine.sparsebundle" with administrator privileges

One possibility is to improve the script by changing the mountpoint from /Volumes to /Volumes/HDDBackup:

try 
mount volume "smb://someserver/DATA" 
end try 
do shell script "/usr/bin/perl -Ue '$< = $>; system(@ARGV)' hdiutil attach -nobrowse -mountpoint /Volumes/HDDBackup /Volumes/DATA/{...}/Timemachine/MGTimeMachine.sparsebundle" with administrator privileges

Probably you have to change your time machine settings afterwards. Please check if this works out for you.

The other possibility is to disable your apple script, restart the Mac, cloning disk0s3 to disk0s2, deleting disk0s3 after booting from disk0s2 and expanding disk0s2 to fill the whole hdd.
Enable your apple script after finishing all steps successfully.

  • Yep, without my faulty mount script, the Volume gets detected correctly and it seems Time Machine runs fine without a change. Disk Utility takes a minute to inspect the Volumes, but I can live with that! I may move my installation to the first partition sometime in the future, thanks for your help - greetings to berlin! ;) – Gotschi Nov 6 '14 at 7:34

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .