18

After I've upgraded to Yosemite, I've started to receive email alerts about upcoming events from my Calendar. This is a typical email

Return-Path: <my-email@gmail.com>
Received: from [192.168.100.245] ([113.163.117.148])
    by mx.google.com with ESMTPSA id gz1sm18613666pbb.8.2014.11.03.21.00.03
    for <my-email@gmail.com>
    (version=TLSv1 cipher=ECDHE-RSA-RC4-SHA bits=128/128);
    Mon, 03 Nov 2014 21:00:04 -0800 (PST)
Date: Mon, 03 Nov 2014 21:00:04 -0800 (PST)
From: My Name <my-email@gmail.com>
Content-Type: text/html;
charset=utf-8
Content-Transfer-Encoding: quoted-printable
Mime-Version: 1.0 (Mac OS X com.apple.MailServiceAgent 8.0 \(1990.1\))
Subject: =?utf-8?Q?Alert_-_=D0=9F=D0=BB=D0=B0=D0=BD=D0=B5=D1=80=D0=BA?=
 =?utf-8?Q?=D0=B0_UC?=
Message-Id: <82009606-9D7A-4238-A09E-7374739780EA@gmail.com>
To: my-email@gmail.com
X-Mailer: Apple Mail (2.1990.1)

4 Nov 2014 14:00 : =D0=9F=D0=BB=D0=B0=D0=BD=D0=B5=D1=80=D0=BA=D0=B0 UC=

My OSX Calendar is connected to my Google Account. And takes events info from Google Calendar.

I have disabled all notifications for OSX Calendar. http://take.ms/ZVQus

But I still receive email notifications about upcoming events. Since I also receive them from Google Calendar, I get all notifications twice.

How to disable them?

19

This worked for me:

Open Calendar on your Mac.

In the left column list of calendars, right click (or command-I) on the calendar in question and "Get Info"

Check the box labeled "Ignore alerts"

Hit "OK"

  • 2
    Do you still get pop-ups doing this? I like the pop-up, I just don't wait the email spam. – levesque Mar 3 '17 at 15:02
  • I do not get pop-ups, but I do not know if I ever disabled or enabled them or if this disables or enables them. I can only tell you I don't get them. – aiwetir Mar 3 '17 at 22:17
5

This is an old post but might be helpful for some.

It turns out, as far as I can tell, that the alert emails originating from the Mac mail app are just following the instructions you have programmed on Google Calendar, much like pop up notifications work.

That being said, as of now, there is no way to ignore than instruction from google calendar unless you remove all alerts from your mac (which also would turn off the pop up alerts, which may or may not be acceptable) or to disable the email alerts from the google calendar side (which will also eliminate the emailed alerts from google, which again, may or may not be acceptable)

Or the third option is to live with the duplicates until apple decides to give us an option to ignore email alert settings from google calendar to avoid having a duplicate.

Hope that's clear and makes sense.

I had called Apple Support and they could not resolve anything either.

  • I have another option. iCloud sends me those notifications from an email adress of the format meself@me.com, I just set up a filter and send all those emails straight in the garbage bin. – levesque Mar 3 '17 at 15:03
  • @user165620 I never asked apple to send e-mails through my company's address (that is the only one setup at Mail) to send e-mails from my personal calendars, that are only setup in Google calendar and macbook Calendar. That's the main problem here I guess. – Ricardo Martins May 29 '17 at 1:19
  • :0: * ^Mime-Version:.*com\.apple\.MailServiceAgent * Subject: Alert - /dev/null works if you control your own .procmailrc. Linebreak before each * and before /dev/null – BaseZen Feb 19 '18 at 21:05
2

I figured it out.

  1. Open Google Calendar on your computer in a browser.
  2. In the top right, click the gear button, then click Settings in the drop down menu
  3. At the top of the Settings page, click the Calendars tab.
  4. Next to your calendar's name, click Edit notifications.
  5. Once on this page you can remove or edit any default notifications. Correct if i'm wrong but you should see a notification in your list that looks like this:

Email notification

  1. Just remove that notification or change it to a different kind of notification (the only other option besides 'Email' is just a regular 'Notification) and you should be all good.
  • I want to have email notifications from Google Calendar. I don't want them from Apple services, since I already have them from Google. – dandaka Sep 13 '16 at 14:52
1

My Cal app on my mac wouldn't let me actually Apply changes and make the alerts "none."

It's a problem with the application, nothing else from what I can tell.

My fix was to go into the Day view and click on the event. Then I changed the Travel Time to something random (like 1.5 hours), and clicked apply.

Once that was applied, I made all of the alerts and travel time None again and hit Apply and it worked. Not sure what this problem is, but took me a while to figure out that I wasn't doing anything wrong.

0

Press Command + , > Alerts. You will then be able to alter your alerts settings. In case this does not help, I suggest going into your Google Calendar settings and checking what type of alerts are enabled. Although it seems like Apple is having these emails sent to you, they are coming from Google. Take a look here too: http://www.solveyourtech.com/how-to-stop-email-notifications-from-google-calendar/. I hope I was able to help you!

  • 1
    1. These are settings for OSX Calendar, all alerts disabled take.ms/bDK8b and take.ms/8HDvY 2. I get two notifications for each event — one from Google Calendar (which is I enjoy) and another from OSX take.ms/0TLKI. I seriously doubt, that second is coming from Google, since it has "Mac OS X com.apple.MailServiceAgent" in header. – dandaka Nov 5 '14 at 14:04
  • This is strange... I'll call or take a look because I upgraded my other computer to Yosemite and I'm having the same answer. I'll get back to you soon. – Bora Nov 5 '14 at 15:12
-1

Calendar > Preferences > Alerts > Uncheck "Time to Leave"

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .