1

I have keys responding problem on a brand new iMac (Yosemite) with new numeric keypad. The right side keys doesn't respond in any application. IT'S NOT the Num Lock (Clear) button! Just checked it. Also checked with old keyboard - same problem and the other way - the keyboard works perfectly on old iMac.

*The problem wasn't there from the initial start - it was ok for day or two. I did many installs (like Adobe CS) and preferences customization in a first day.

1

Just found it! In Accessibility preferences (Yosemite) > Mouse & Trackpad "Enable Mouse Keys" must be uncheked. Otherwise numbers behaves like arrows. Yoo-hoo, what a relief )

  • Having Mouse-Keys available can be useful for the rare times your battery goes flat, or even very very rarely, if the mouse fails to be recognised. It means you can at least get around the screen. You can toggle it by hitting the Opt key 5 times quickly [there's a tiny sound like someone dropped a ball-bearing] The switch is in Options next to the Mouse Keys toggle. – Tetsujin Nov 5 '14 at 7:54

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .