1

After upgrading to Yosemite, I'm having an issue with Apache and PHP running locally.

PHP can't find my local database server using localhost but it can if I specify 127.0.0.1 or test.dev (which resolves to 127.0.0.1). I tried both the shipped version of PHP (5.5.14) and 5.5.18 from homebrew. Both exhibit the same behavior.

The database server is not configured to deny connections on localhost; Sequel Pro can connect via socket just fine.

I've tried enabling and disabling all of the provided Apache modules to no effect. No matter what I do, it can't seem to connect to localhost. What could be happening here? OS X firewall is off and Little Snitch is not running.

My /etc/hosts:

##
# Host Database
#
# localhost is used to configure the loopback interface
# when the system is booting.  Do not change this entry.
##
127.0.0.1   localhost
255.255.255.255 broadcasthost
::1             localhost 

Update:

I tried NGINX as a webserver and PHP (both from homebrew) is able to connect to localhost. Any more ideas as to why it would behave this way? What could Apple have done to their configuration of Apache in Yosemite that would cause this? What is gained from disallowing/denying connection to localhost?

  • Can you paste your /etc/hosts? – jherran Nov 4 '14 at 21:31
  • My /etc/hosts should not be the issue, but I've added it above. – Brendan Nov 4 '14 at 21:35

You must log in to answer this question.

Browse other questions tagged .