2

I just upgraded my 2010 MacBook Air to Yosemite. It froze during installation, I shut it down and when I restarted it booted normally to Yosemite.

Now everything seems to be working ok, but I have no sound. My case is not like most cases where it defaults to an external device. I have nothing attached, no monitors, no external speakers.

When I check system preferences/sound, I get no output devices found.

Here's what I've tried: - rebooting - reset NVRAM - reinstalling yosemite (same freezing problem - waited for 4 hours) - remove plist files from Library/preferences/audio and restarting

Any suggestions?

Thanks

  • Hey im having the same issue right now. no red light no input/output and even the usb access on the same side doesn't work! May I ask if you have solved this issue yet? – user119696 Mar 26 '15 at 21:31
1

Reset the SMC:

1) Power down the system
2) Unplug all cables except Magsafe
3) Hold down left Shift + Control + Option + Power button for ~5 seconds
4) Boot machine up

This usually solves issues when certain hardware devices on the device itself aren't responding, especially when multiple do not work.

| improve this answer | |
0

Reset the SMC and then check the headphone port for lint or materials.

If the SMC reset doesn't make a difference then restart the sound controller:

Open Activity Monitor locate 'coreaudiod' in the list of processes, select it and click on the X to quit that process. The process will restart straight away and in doing so may fix your problem.

| improve this answer | |

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .