4

I recently purchased a new Macbook Pro Retina (15-inch, Mid 2014). I installed a few normal programs (DropBox, 1Password, etc.). I did not open the Mail app at all. I then upgraded to Yosemite. After a seemingly successful upgrade, when I tried to open Mail for the first time, it hung without displaying any screens (though the menu bar does display). Leaving it for several minutes has no effect. Clicking anywhere transfers focus to a new application, causing the Mail menu bar to disappear. Clicking on the Mail icon again has no effect. Activity Monitor shows "Mail (No Responding". It uses no CPU and little memory (13.1 MB). Nothing obviously mail related (to me) appears in the System Log Console.

As part of troubleshooting, as recommended on a MacIssues.com article, I removed the Mail app Container (Macintosh HD ▸ Users ▸ rileymajor ▸ Library ▸ Containers). It rebuilt it on the next launch, but it seemed to have no effect.

How can I make my Mail app work, preferably without reinstalling the OS or other similarly drastic measures?

I have not configured any mail settings and have no saved mail to worry about. I just need it to run.

I have 4 Internet Accounts configured:

  • iCloud
    • Photos
    • Contacts
    • Calendars
    • Reminders
    • Safari
    • Find My Mac
  • Google
    • Contacts
    • Calendars
  • Twitter
  • LinkedIn (Contacts not selected)

I have no mail configured.

  • May I ask a question? Do you have any linked mail accounts to your MacBook Pro already? You can check this in System Preferences -> Internet Accounts (the big blue @ symbol) – Benjamin R Nov 4 '14 at 3:46
  • did you set up any mail accounts in the syst pref internet accounts? – Ruskes Nov 4 '14 at 3:47
  • @BenjaminR Nope. – Riley Major Nov 4 '14 at 3:53
  • @RileyMajor right... Do you want to try adding one and see what happens? In theory it shouldn't make any difference, but I just want to eliminate it as a possibility... – Benjamin R Nov 4 '14 at 3:57
  • Adding an account seemed to help. The application now loads. Clicking on Get Mail does nothing. Sending a message works, but so far no IMAP folder tree or stored messages appear. Thanks for your help so far. I will keep this thread updated. – Riley Major Nov 4 '14 at 4:09
3

Try linking/adding a mail account to your Mac through System Preferences -> Internet Accounts. See if that fixes it.

(Which of course, it did. Might as well get the rep for it ;D )

  • Can you share your reasoning for this? I have the same symptoms but this didn't fix it. – lukecyca Jan 30 '15 at 18:36
  • @lukecyca It seemed like it was a workaround to a bug with the newly-released Yosemite as opposed to previous version of Mail where upon loading Mail for the first time it would ask to add an account. Was your Yosemite install an upgrade or clean/fresh install? – Benjamin R Jan 30 '15 at 20:15
  • Thanks. Mine was a fresh install but I found that my problem was due to a badly-encoded message that I received. I deleted it using another mail client and now Mail.app is fine. – lukecyca Feb 4 '15 at 20:58
0

I solved this disabling all mail accounts from System Preferences by unchecking their Mail checkboxes. While doing this I had to authenticate for some accounts (which may have solved the issue).

Then successfully launched Mail. After that re-enable your Mail accounts from System Preferences one by one.

You must log in to answer this question.

protected by Community Mar 20 '15 at 0:18

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged .