0

Alright so here's my issue. I've searched the web for quite some time and hopefully I can find some better info here.

I used to have a Time Machine that was set to backup an older Macbook Pro. The Macbook Pro and TM both are dead, but I have saved the hard drive out of the TM. I now have a newer Mac Mini.

So I'm attempting to somehow access the files located on the old TM drive by connecting it through a dock to my Mac Mini, but can't seem to get that to work. The .sparsebundle file located on the drive is shown with a red circle with white bar icon, and I have no access or ability to double click and open the sparse bundle.

Is there a way I can change the permissions on this file to be able to open it? I'm completely at a loss here of what to do.

I'm fairly confident all of my data is located in the .sparsebundle. Finder shows the 2TB drive has over 1.3TB used. I also tried to verify disk in disk utility and it said the drive was fine.

Update So I managed to just right click the lock icon on this sparsebundle file and change permissions to read only. Now when I try to double click the .sparsebundle, it tells "Image not recognized". In disk utility, this sparsebundle appears in the left, with a volume underneath it called "Time Machine 3". I cannot run verify/repair on the .sparsebundle itself, but I can on the Time Machine 3 after mounting it, and it runs and says the disk is ok. The disk pops up and I can navigate to it in Finder, but this still doesn't allow me to access my files and folders saved on it. -__-

It seems like all of the actual data is stored in some cryptic "bands" folder.

  • Which OS? I've been having major headaches with Time Machine on my Mac Mini with Yosemite. To attempt what you're trying, I definitely want a 10.9 or lower. – Wayfaring Stranger Nov 4 '14 at 0:43
  • The Mac Mini I'm using to try and recover with is running 10.9.5 – krb686 Nov 4 '14 at 0:52
  • Im just gonna leave this here: pondini.org/TM/Troubleshooting.html – ProfFrnswrth Nov 4 '14 at 1:07
1

Time Machine backups cannot be browsed in Finder. You must view them through Time Machine.

If you are using a computer that is different from the one where the backup was made, there are additional steps. The Time Machine - Troubleshooting page explains further.

Time Machine keeps the backups for each Mac separate, and normally only shows the ones for the Mac it's running on (selected in the Time Machine Preferences window), even if there are other backups of the same or a different Mac on the same or different disk/partition.

To see these "other" backups, you need the Browse Other Backup Disks or (Browse Other Time Machine Disks on Snow Leopard or Leopard) option. It's available by Alt/Option-clicking the Time Machine icon in your Menubar, or by control-clicking (right-clicking) the Time Machine icon in your Dock.

You'll see a selection screen showing all the mounted disks/partitions that have Time Machine backups on them. Select the one you want, click Use Selected Disk, and you'll be taken to the normal "Star Wars" display, where you should see all the backups on that disk/partition.

You may not be able to restore such items normally (to their original location); if not, you'll need to restore them to an alternate location per Frequently Asked Question #16.

  • For those down-voting, note that this answer was correct at the time it was posted. Newer versions of Time Machine produce a different type of backup that can be browsed manually as the other answer shows, but the backup referenced by the OP (which has the "bands" folder present) cannot. – tubedogg Aug 9 '17 at 0:42
-1

Double-click on the .sparsebundle file. This will mount it like an external disk: desktop

Then, open the Backups.backupdb folder. This reveals a lot of folders like this: folders

This is a problem, right? Well, actually, no. Because if you scroll down to the bottom, there is an alias titled "Latest", like this: latest

Opening the alias will take you to your most recent backup. Just go through the list of folders and copy all of the files you want. documents

Let me know if you have any problems with this or want some help!

  • This doesn't address the question because it reflects a newer format of Time Machine backup than the OP was trying to access. (The "bands" folder is no longer present in newer versions, as your steps show.) The OP's Time Machine backup cannot be browsed this way. – tubedogg Aug 9 '17 at 0:41
  • @tubedogg I’m not sure I understand your comment. Is OP using a newer or older version of time machine than I am? And what determines time machine versions, as the backup shown was made on MacOS 10.12.6. – NoahL Aug 9 '17 at 1:09
  • 1
    It was an older version, as shown by the OP referencing trying to access the "bands" folder which is not present in your screenshots. – tubedogg Aug 9 '17 at 1:11
  • By version I am referring to the OS in which the backup was made. The version of macOS you are running did not exist in 2014 when the question was asked. (10.12.6 was available when you posted this answer in October 2016?) – tubedogg Aug 9 '17 at 1:13
  • Oops @tubedogg. I was running whatever the highest public beta OS was at that point. But the same steps hold true for 10.12.6 (I made a new backup and used these steps about a week ago). – NoahL Aug 9 '17 at 1:19

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .