3

In iTunes, in "On This iPhone" I have all of my music files deleted, but on my iPhone in the "Music" app it shows a bunch of my old music albums and files, opening an album it has the "Download from Cloud" icon to the right, so it is not really on the iPhone.

How can I get rid of all these old albums/files cluttering my iPhone Music app? I will never want to download them from the cloud, and they are still there even after I tried restoring my phone.

Thank you.

1

Settings > music > show all music - toggle to off.

1

Not sure if this will work for you, but in my case, my music was showing on my iPhone, but not on my computer in my iTunes, and when connecting my iPhone to my computer the songs listed in the computer's iTunes under my iPhone were low too......I finally checked my iCloud account, and re-signed in to be sure, and THAT fix it. My songs are back on both my phone and computer! So make sure you are signed in to BOTH iTunes and iCloud!

0

figured it out...open the Music app on your iPhone...make sure My Music is selected at the bottom...Click the red drop down menu that says either Artists or Songs or Albums etc...at the bottom of drop down menu there's a tab to turn on that says Only Offline Music...that'll Show only music stored on your iPhone, not all of the past purchases

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .