10

After upgrading to Yosemite, I found there are quite some Google Chrome Helper (not responding) processes after MacBook resumes from hibernate (closing the MacBook cover).

It seems to me close-and-reopen Chrome will clean up the (Not Responding) processes.

What is the problem?

enter image description here

7

You can see developers from the Google Chrome team discussing the issue here.

If I'm reading correctly, something triggers a change in the way things are drawn to the screen. The WindowServer process, which is responsible for drawing everything to the screen, issues a notification announcing that change to every process with a GUI and expects an acknowledgement of the notification. These Chrome processes don't respond, so the operating system flags the processes as "Not responding".

Long story short is that they think this is just a cosmetic problem that will be fixed shortly. It doesn't actually seem to affect performance.

They've found and fixed similar issues in the past, for example 304860. I think this is a side-effect of the multi-process architecture that they use for Chrome.

1

It seems like the problem is now fixed with Google Chrome Version 39.0.2171.65 (64-bit). Mine wasn't updated automatically from version 38, so

Just uninstall and download new one then install

Hope this helps.

Lots of Chrome extension without Not responding

0

Wired.com has a succinct article here which brings up some interesting points:

The quick story is that Google Chrome Helper isn’t really the problem. It tends to go on the rampage when there’s a rogue extension or when Google Chrome’s plug-in settings are configured to run everything by default. ... but most users in the Help Center forums seem to run into trouble when it’s working with Flash content.

“Google Chrome Helper” is the generic name for embedded content that runs outside the browser. Browser plug-ins aren’t features that are rendered by HTML code; they involve content that needs to be pulled in from elsewhere. ...

The fix:

Disabling Helper’s auto-helping is easy, and it won’t prevent you from using plug-ins. You’ll just have to opt in to view plug-in content on a case-by-case basis. ... First, shut down all your Chrome windows without quitting the program. In the Chrome menu, go to “Preferences,” scroll all the way down in the menu, and click on “Show advanced settings…” The first item in the expanded advanced settings list will be “Privacy,” and click on the “Content Settings” button right under that. About halfway down the content settings list is a “Plug-ins” entry, which will likely be set to “Run automatically.” Instead, select “Click to play.”

I know this is a lot of copy 'n' paste, but it is some very interesting information.

  • That article is actually quite bad. The Chrome Helper processes aren't just plugins. There is a Google Chrome Helper process for each tab you have open, for each extension you have installed, for each plugin that is currently running and one to talk to the GPU in your system. It isn't "the generic name for embedded content" and you can't "[destroy] the Google Chrome Helper". – Alistair McMillan Dec 16 '14 at 12:48
-1

go to chrome://flags

look for something with sandbox

click disable -> restart chrome

enter image description here

  • Which Chrome flag are your recommending? – Graham Miln Nov 18 '14 at 6:07
  • check my edited answer – Radu Toader Nov 18 '14 at 8:37
  • What does disabling this do for the problem the OP mentions? I've done some additional research on your answer based on the link provided by Graham Miln, and it doesn't really have anything to do with Google Chrome Helpers. There are other Sandbox flags, "--allow-no-sandbox-job" which may, tangentially, have something to do with Chrome Helpers, but I doubt it. Please provide some proof of your assertion. – IconDaemon Nov 18 '14 at 12:38

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .