530

Would it be possible to configure iTerm 2 to go backwards and forwards one word through the curent text in the command line using a keyboard shortcut?

3
  • 63
    This doesn't really answer the question but it's relevant: you can option+click anywhere in a command line to move the cursor there. Commented Apr 19, 2018 at 22:52
  • @P-i- Why do you think that accepted answer is not the correct one? 1. It appeared almost 3 years before the one with most votes. 2. It presents a solution that doesn't works by default.
    – syntagma
    Commented Aug 21, 2019 at 18:23
  • 3
    @P-i- You should only downvote a question if the question itself has problems, not because you disagree with OP's actions
    – TerryA
    Commented Mar 21, 2020 at 0:17

12 Answers 12

104

Ctrl-[ b jumps back a word. You can also use Esc instead or Ctrl-[, and f to go forward.

That is Ctrl+[ release and then b orf. Or Esc and b or f.

More information can be found at this other discussion on AskDifferent.

5
  • 19
    This would be better if there was a way to go back lots of words quickly while holding down a button, as opposed to having to type a sequence of keys for each word. Commented Feb 28, 2019 at 19:43
  • 2
    What is "Ctrl-[" ?
    – Shihao Xu
    Commented Aug 20, 2019 at 22:57
  • 1
    With "Ctrl-[ " I mean hitting the "Ctrl" key and "[" key simultaneously.
    – Volsk
    Commented Aug 23, 2019 at 8:33
  • 30
    Answer below by Ricardo Stuven is the right answer
    – user603749
    Commented May 11, 2020 at 13:46
  • Yes, Just vist the next answer but not the adpoted one.
    – Carl Lee
    Commented Sep 1, 2020 at 9:03
1327

Killing a fly with a cannon:

  1. Go to iTerm2 (in the menu bar) > Settings... > Profiles > Keys (not "Preferences... > Keys"!),
  2. On current versions (since version 3.4.9): switch to the Key Mappings tab,
  3. Press Presets... dropdown button,
  4. Select Natural Text Editing.

screenshot of dialog with Presets

Then, you can

  • move a word backwards Option ⌥ +
  • move a word forwards Option ⌥ +
  • move to the start of the line fn +
  • move to the end of the line fn +
  • delete a word backwards Option ⌥ +
  • delete the whole line Command ⌘ +

If the preset doesn't appear, reinstall iTerm2. If you installed it using Homebrew+Cask:

brew cask reinstall iterm2

or since Homebrew 2.6.0 (December 2020)

brew reinstall --cask iterm2
23
  • 8
    This is great and will add most of your needs. It however does not add a 'go to start/end of line via CMD + left arrow/right arrow`. For that action, see: stackoverflow.com/questions/6205157/…
    – MikeyN0
    Commented Oct 3, 2018 at 23:07
  • 8
    Go to iTerm Preferences → Profiles, select your profile, then the Keys tab. Click Load Preset... and choose Natural Text Editing. Commented May 7, 2021 at 8:39
  • 3
    THANKS, this has to be the correct/verified answer!. ✌🏼 Commented Aug 27, 2021 at 9:06
  • 25
    With the new versions you'll need to go to Key Mappings then select a preset. You could also use Terminal.app Compatibility which gives the same result.
    – Ibrahim.H
    Commented Sep 23, 2021 at 8:19
  • 4
    why isn't this the accepted answer? This definitly is the best one! Thx
    – Naderio
    Commented May 30, 2022 at 7:40
196

I like the following setup.

  1. Preferences > Keys (or Preferences > Profiles > Keys)
  2. Click the plus.

move forward one word

option+right
send escape sequence
f

move back one word

option+left
send escape sequence
b

delete to beginning of word (credit)

option+delete
send hex code
0x1B 0x08

delete to end of word

fn+option+delete
send escape sequence
d

(I don't remember for sure, but I think I copied this answer from jherran's answer below and added more to it. I should have added the extra information in comments or suggested edits on that answer. I don't know how to improve the situation, but now it's known.)

12
  • 3
    On MacOS 10.12, I need to use hex code 0x17 to get delete to beginning of word
    – midopa
    Commented Jan 20, 2017 at 4:16
  • works like a charm with macOS 10.12 and zsh
    – Sébastien
    Commented Feb 7, 2017 at 14:23
  • 1
    best answer ever you have a beer from me :)
    – infinity
    Commented Jun 9, 2017 at 13:46
  • 2
    Consider upvoting jherran's answer. I think I just improved on their answer a little and probably should have suggested an edit instead of creating my own answer. I kind of feel like I stole it. Commented Jun 17, 2017 at 2:54
  • 1
    I created the shortcuts as suggested but initially they didn't work as they were being overridden by keyboard shortcuts in my profile (see profile menu). Deleting the respective entries in my profile seems to have done the trick. Commented Feb 20, 2019 at 14:25
51

To Get Forward (Alt-f), Backward (Alt-b) and Delete (Alt-d) Word

  1. Open iTerm.
  2. Go to iTerm > Preferences... > Profiles > Keys
  3. Under Profile Shortcut Keys, click the + sign.
  4. Type your key shortcut (option-b, option-f, option-d, option-left, etc.)
  5. For Action, choose Send Escape Sequence.
  6. Write b, d or f in the input field.

This works at least for bash. For zsh there are other ways to navigate.

6
  • 2
    I tried to add an option+right shortcut and got a warning message about a conflict, because I didn't realize that you can configure keys both in Preferences > Keys > Global Shortcut Keys and also Preferences > Profiles > Keys > Profile Shortcut Keys. Configuring it in the default profile worked. Commented Sep 8, 2015 at 3:48
  • 1
    It works for zsh as well! Commented Jun 30, 2017 at 16:33
  • 2
    I think your answer (to the same solution) was the easiest to understand +1
    – nzaleski
    Commented Oct 29, 2018 at 12:39
  • 1
    Very useful explanation.
    – Conti
    Commented Jan 28, 2019 at 10:37
  • Perfect. You can also use Command+F etc so the "Alt" key is in the same position and no adjustment is necessary when switching between PC and Mac. Commented Sep 8, 2019 at 17:59
24

In build 3.3.12, you can select the Natural text editing preset and it will add all the necessary escapes to make it feel like you're navigating text in any other app.

enter image description here

4
  • 2
    I have 3.4.15 and these options are gone (only defaults). Moreover, I can't find where to download these itermkeymaps...
    – rafraf
    Commented Dec 29, 2021 at 13:25
  • 1
    Thank you for the screenshot. This made is easy for me to get this small feature back. Commented Mar 19, 2022 at 5:50
  • 2
    @rafraf, I had that problem too, but I was looking at the wrong screen. Make sure you're on Settings -> Profiles -> Keys, and not on Settings -> Keys -> Key Bindings!
    – JakeRobb
    Commented May 1, 2023 at 16:23
  • How is this different from the Ricardo's THREE years older answer? Commented Sep 10, 2023 at 19:07
23

Similar to other answers, but for Zsh it took me a while to find this:

If you are using Zsh, like Oh My Zsh, in iTerm then go to: Preferences > Profiles > Keys sub-menu

Click + sign

Add your shortcut combo, choose "Send Escape Sequence"

inputs for left and right below.

left:

[1;5D

right:

[1;5C
6
  • 2
    You saved my life mate Commented May 31, 2017 at 8:40
  • This is the only solution that worked for me
    – Bryji
    Commented Oct 2, 2017 at 10:44
  • Finally, a simple solution that works :D Thanks for sharing it with us! Commented Aug 1, 2018 at 7:08
  • This should be the answer. Upvoted.
    – ehime
    Commented Sep 27, 2019 at 17:16
  • Thanks, man, this is the best possible way IMO. Commented Feb 19, 2020 at 16:39
11

enter image description here

Open Preferences

Configure Left (and / or) Right Option key to send Esc+

If you messed with your presets, you may need to load the default preset (beware this could wipe your custom keybinds!)

enter image description here

If you see weird characters after you do this you may need to configure your ~/.inputrc or /etc/inputrc

Add this to your ~/.inputrc:

"\e[1;5C": forward-word
"\e[1;5D": backward-word
"\e[5C": forward-word
"\e[5D": backward-word
"\e\e[C": forward-word
"\e\e[D": backward-word

full example inputrc:

# /etc/inputrc - global inputrc for libreadline
# See readline(3readline) and `info rluserman' for more information.

# Be 8 bit clean.
set input-meta on
set output-meta on

# To allow the use of 8bit-characters like the german umlauts, uncomment
# the line below. However this makes the meta key not work as a meta key,
# which is annoying to those which don't need to type in 8-bit characters.

# set convert-meta off

# try to enable the application keypad when it is called.  Some systems
# need this to enable the arrow keys.
# set enable-keypad on

# see /usr/share/doc/bash/inputrc.arrows for other codes of arrow keys

# do not bell on tab-completion
# set bell-style none
# set bell-style visible

# some defaults / modifications for the emacs mode
$if mode=emacs

# allow the use of the Home/End keys
"\e[1~": beginning-of-line
"\e[4~": end-of-line

# allow the use of the Delete/Insert keys
"\e[3~": delete-char
"\e[2~": quoted-insert

# mappings for "page up" and "page down" to step to the beginning/end
# of the history
# "\e[5~": beginning-of-history
# "\e[6~": end-of-history

# alternate mappings for "page up" and "page down" to search the history
# "\e[5~": history-search-backward
# "\e[6~": history-search-forward

# mappings for Ctrl-left-arrow and Ctrl-right-arrow for word moving
"\e[1;5C": forward-word
"\e[1;5D": backward-word
"\e[5C": forward-word
"\e[5D": backward-word
"\e\e[C": forward-word
"\e\e[D": backward-word

$if term=rxvt
"\e[7~": beginning-of-line
"\e[8~": end-of-line
"\eOc": forward-word
"\eOd": backward-word
$endif

# for non RH/Debian xterm, can't hurt for RH/Debian xterm
# "\eOH": beginning-of-line
# "\eOF": end-of-line

# for freebsd console
# "\e[H": beginning-of-line
# "\e[F": end-of-line

$endif
2
  • 1
    Perfect... tks.
    – paivaric
    Commented Oct 18, 2019 at 23:51
  • No problem! Glad it helps :)
    – yosefrow
    Commented Oct 22, 2019 at 10:18
4

For new version of iterm 2 (3.4.4), I had to use the suggestion from https://coderwall.com/p/a8uxma/zsh-iterm2-osx-shortcuts. This work specifically for zsh

In zsh you can use ctrl + a/e to move to beginning/end of line and esc + W/B to move one word backward/forward, but that's not very handy.

Here is a solution to map ⌥ + ← / → and ⌘ + ← / → to work in iTerm2 as expected

Put this in your .zshrc

bindkey "[D" backward-word
bindkey "[C" forward-word
bindkey "^[a" beginning-of-line
bindkey "^[e" end-of-line
3
  • 1
    This is incomplete - as the URL also says you need to chnage things in iTerm - why do you think you do not need to do this?
    – mmmmmm
    Commented Apr 3, 2021 at 10:10
  • 1
    Worked perfectly for me with iTerm 3.4.16 and zsh. Thanks!
    – BiBi
    Commented Sep 15, 2022 at 1:53
  • As of Oct 3, 2022 - This works for me on Mac OS 12.6 and Iterm2 3.4.16
    – papar
    Commented Oct 2, 2022 at 18:28
3

You can set your terminal in vi mode with set -o vi to be able to use the usual vi motion commands (add the line in .bash_profile to store the setting permanently.)

So, as if in vi, you can hit Esc, then b to move one word backward (w for forward), go to the beginning of the line with 0, or search a character backward with F + the char.

Hit i to go back to Normal mode and insert.

Those familiar with vi can do much more. A cheat sheet can be found here.

2
  • 2
    vim solves everything! :D Commented Jun 20, 2018 at 20:19
  • Hitting Esc then I to just go once to the beginning of the line is slightly less convenient than Ctrl-a - this use case happens often when you just want to modify the command name. So I use vi mode with some keybinding changes in iTerm2 to map Ctrl-A and similar to escape sequence Esc+0. That way these cases are even faster as it ends in edit mode.
    – rfabbri
    Commented Aug 6, 2019 at 17:59
0

Answer with more intuitive word breaks. If I have:

ls foo/bar foo/bar/baz

I want a word to be foo/bar, not foo. It took a while a while to get that working.

From this I added to .bash_profile:

# Use Ctrl-g instead of Ctrl-f because Ctrl-f is mapped in macs to Find
bind '"\C-g":vi-fWord'
bind '"\C-b":vi-bWord'

From what I could tell, it's not possible to mention Option key in .bash_profile. So I had iTerm2 map from C-g -> Option-right, C-b -> Option-left:

Screenshot of iTerm2 Preferences

0

For those how are interested this issue has the solution https://gitlab.com/gnachman/iterm2/-/issues/9806

0
-1

With iTerm2 3.1.4, I was able to setup the following without adding individual key mappings.

  1. Go to Preferences > Profiles > Keys
  2. Left/Right ⌥ Key: Select Esc+

With a new Terminal session you are now able to use:

Option ⌥ + f to Get Forward

Option ⌥ + b to Get Forward

Option ⌥ + Delete ⌫ to Delete Word

1

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .