2

I am trying to set up a proxy on my iPhone, so that I can view web traffic coming in and out of it. I've tried using a few tools such as Charles and Mitmproxy, but every time I set the HTTP Proxy for my wifi on my phone and open Safari, it just says that the network connection was lost.

I turned on the proxy, and set the proxy settings using the IP of my mac which I obtained like this

enter image description here

and then I set my HTTP proxy settings on my iPhone like this:

enter image description here

Then I try to use Safari and it says "Network Connection Lost." I'm not sure what I'm doing wrong or if the instructions I've been following are out of date for iOS 8. Any help would be appreciated!

Some other information that might be useful, I've tried this with a bunch of different proxy tools and the same issue has occurred with all of them, and I've tried changing the port I'm using the proxy on.

  • Please specify the IP-settings of the iPhone and the Mac OS X version (i expect the iOS version to be 8.1) – klanomath Nov 2 '14 at 2:01
  • What IP settings of the phone do you need? My iOS version is 8.0 and I'm using 10.10 for OS X – Billy Jacobson Nov 2 '14 at 2:15
  • DHCP or manual. You didn't upgrade to iOS 8.1? Without proxy the iPhone works undisturbed? – klanomath Nov 2 '14 at 2:30
  • I just upgraded to 8.1 and still have the same issue. I'm using DHCP for my IP and then the HTTP Proxy is manual – Billy Jacobson Nov 2 '14 at 2:35
  • I also tested running the proxy through my own computer and seeing if mitmproxy could detect it, and it worked fine, so I think it must be some sort of configuration on my phone, but everything I'm reading online makes it seem like it should just work. Could it be something with my wifi? – Billy Jacobson Nov 2 '14 at 2:44

You must log in to answer this question.

Browse other questions tagged .